SYMPTOM
Continuously sending large report/document to History list multiple time over the setting in “If manually, how many of the most recently run reports and documents do you want to keep available for manipulation” would return error for all messages in Strategy Web 10.4-10.7
Follow the steps below to reproduce the issue in Tutorial project:


Here, the cache configuration, history list directory and privileges are configured properly. And the Working set memory has been set as a large enough value.
And if in step 3, the reports sent to History List is not larger than the setting in step2, all messages will be executed correctly without error.
Above issue is not observed in 9.x version.
Note:
It doesn't mean that as long as users send more reports than the setting value to History list, the issue would happen 100%.
It depends on how many report requests are queued. The reports can be the same one or different ones.
If the report number in the queue is larger than the setting, this issue would happen.
CAUSE
This is a known issue with Strategy 10.4-10.7.
ACTION:
This issue has been addressed in Strategy 10.4HF4 and 10.8. Please upgrade to take the advantage.
WORKAROUND
Increase the setting in step 2 to a large enough value, more than the times a report may be continuously sent to History List.
The side effect is that, if the memory occupied by the increased messages exceeds working set RAM, the old messages in working set will be moved to the directory configured via TmpPool parameter. Then the performance might be expected to decrease when such report/documents are accessed again, as they would be reloaded in working set again and this would consume some time, compared with those messages which already exist in working set.
The Strategy Internal Reference Number for the issue discussed in this technical note is DE60272 KB39324