EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB439324: Continuously sending large report/document to History list multiple time would return error for all messages in MicroStrategy 10.4-10.7


Min Zheng

Senior Manager, Cloud Support • MicroStrategy


SYMPTOM
Continuously sending large report/document to History list multiple time over the setting in “If manually, how many of the most recently run reports and documents do you want to keep available for manipulation” would return error for all messages in Strategy Web 10.4-10.7
Follow the steps below to reproduce the issue in Tutorial project:

  • Prepare a report whose execution takes at least 1 minutes and clear the report cache.
  • In Web, for the setting: Preferences > Preferences Level_Project Defaults > Preferences_History List: If manually, how many of the most recently run reports and documents do you want to keep available for manipulation, set to 3.
  • Run the report. In wait page, click on “Send to History List”. And then click on the folder path to return to folder.
  • Repeat step 3 for 3 more times, so that there are totally 4 reports sent to History List, which is more than setting in step 2.
  • Wait for a while. All 4 messages in History List returned error. The error details can be either of below:

    User request is queued. 
    MsiUserInBox: Failed to persist the results of this message. Please check that the cache configuration is proper and that the history list directory as specified in the server definition exists on the Intelligence Server machine. 
ka02R000000kb8QQAQ_0EM44000000QCu5.jpeg
  • or

    Job expired.
    The results for this report are no longer available.
    Possible reasons are a)History List message results are unavailable, b)Insufficient privileges for executing reports simultaneously, or c) the Working Set has reached the maximum number of reports.
ka02R000000kb8QQAQ_0EM44000000QCuA.jpeg


Here, the cache configuration, history list directory and privileges are configured properly. And the Working set memory has been set as a large enough value.  
And if in step 3, the reports sent to History List is not larger than the setting in step2, all messages will be executed correctly without error.
Above issue is not observed in 9.x version.
Note:
It doesn't mean that as long as users send more reports than the setting value to History list, the issue would happen 100%. 
It depends on how many report requests are queued. The reports can be the same one or different ones.
If the report number in the queue is larger than the setting, this issue would happen. 
 
CAUSE
This is a known issue with Strategy 10.4-10.7.
ACTION:
This issue has been addressed in Strategy 10.4HF4 and 10.8. Please upgrade to take the advantage.
WORKAROUND
Increase the setting in step 2 to a large enough value, more than the times a report may be continuously sent to History List.
The side effect is that, if the memory occupied by the increased messages exceeds working set RAM, the old messages in working set will be moved to the directory configured via TmpPool parameter. Then the performance might be expected to decrease when such report/documents are accessed again, as they would be reloaded in working set again and this would consume some time, compared with those messages which already exist in working set.
The Strategy Internal Reference Number for the issue discussed in this technical note is DE60272 KB39324


Comment

0 comments

Details

Knowledge Article

Published:

December 27, 2017

Last Updated:

May 7, 2018