EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

10.713: Advanced Data Warehousing


Stefan Zepeda

Salesforce Solutions Architect • Strategy


Learn about advanced issues in data warehousing design and how to work with these complexities when implementing a MicroStrategy project. Understand how to model complex hierarchies and attribute relationships, implement role attributes and slowly changing dimensions, design the schema for optimal performance, use logical views to solve data modeling and schema design issues, and optimize query performance using both the database and MicroStrategy functionality.

SYMPTOM:
When attempting to start the Enterprise Manager service in Strategy 10.0 Hotfix 1 on Linux operating systems, the service fails to start and the following error is displayed:


mstrexec-emservice: WARNING: missing directory '/opt/MicroStrategy/_jre/lib/sparcv9/server'
mstrexec-emservice: WARNING: missing directory '/opt/MicroStrategy/_jre/lib/sparcv9'
Error while trying to launch application:
Unknown error: Check dependencies
For more information try launching 'EMService.exe -logsettings' to get the resulting EMService.log file
(typically, this file is located at C:\Program Files\Common Files\MicroStrategy\Log).
If there is still a problem, please contact Strategy Technical Support.

 
CAUSE:
The Enterprise Manager startup script installed by Strategy 10.0 Hotfix 1 incorrectly specifies the processor architecture as "sparcv9" instead of "amd64".  This issue has been resolved as of Strategy version 10.1.
 
ACTION:
Upgrade to the latest platform release or feature release version of Strategy.
 
WORKAROUND:
Users can modify the Enterprise Manager startup shell script to specify the correct processor architecture, allowing the script to execute normally.  The shell script is named "mstrexec-emservice.10.0.2600.0009" and is located in the "<MSTR_HOME>/bin" folder.  By default this will be "/var/opt/MicroStrategy/bin".  As shipped, the contents of this script are as follows:

#! /bin/ksh
#
# This is the startup script for
# Strategy EM Service
#
# Copyright (c) 2003-2004 Strategy Incorporated
#

. "$(dirname "$0")"/../env/Principal.sh
. "${MSTR_HOME_PATH:?}"/env/BinaryPaths.sh
. "${MSTR_HOME_PATH:?}"/env/Registry.sh
. "${MSTR_HOME_PATH:?}"/env/JVM.sh
. "${MSTR_HOME_PATH:?}"/env/ODBC.sh

export MSTR_JAVA_VMS_LIB="${JAVA_HOME:?}"/lib/sparcv9
export Strategy_JAVA_VM_PATH="${JAVA_HOME:?}"/lib/sparcv9/server/libjvm.so

mstr_prepend_path LIBPATH ${MSTR_JAVA_VMS_LIB:?}/server
mstr_prepend_path LIBPATH ${MSTR_JAVA_VMS_LIB:?}

#preload this libraries
export LDR_PRELOAD64=libjvm.so:${LDR_PRELOAD64}
export LDR_PRELOAD64=libjava.so:${LDR_PRELOAD64}
export LDR_PRELOAD64=libmlib_image.so:${LDR_PRELOAD64}

exec "${MSTR_INSTALL_PATH:?}"/bin/MSTRExec "$@" --noconsole

 
The corrected script should read as follows (note the removed sections):

#! /bin/ksh
#
# This is the startup script for
# Strategy EM Service
#
# Copyright (c) 2003-2004 Strategy Incorporated
#

. "$(dirname "$0")"/../env/Principal.sh
. "${MSTR_HOME_PATH:?}"/env/BinaryPaths.sh
. "${MSTR_HOME_PATH:?}"/env/Registry.sh
. "${MSTR_HOME_PATH:?}"/env/JVM.sh
. "${MSTR_HOME_PATH:?}"/env/ODBC.sh



exec "${MSTR_INSTALL_PATH:?}"/bin/MSTRExec "$@" --noconsole


Comment

0 comments

Details

Knowledge Article

Published:

April 27, 2017

Last Updated:

April 27, 2017