EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB483340: After upgrading to MicroStrategy 2019 Update 1, an error message appears when starting the MicroStrategy PDF Exporter service.


Community Admin

• Strategy


Users recieve the error "Error creating bean with name 'puppeteerService': Invocation of init method failed; nested exception is java.io.IOException: Cannot start up Puppeteer, error" when using the MicroStrategy PDF Exporter service after upgrading to Update 1.

Symptom 


After upgrading to Strategy 2019 Update 1, starting the Strategy PDF Exporter service in Service Manager causes an error to appear.
The error reads:
 
Failed to start service
Error Code: 1
Error Message: Error creating bean with name 'puppeteerService':
Invocation of init method failed; nested exception is java.io.IOException: Cannot start up Puppeteer, error:
 

ka04W000001Ix0fQAC_0EM2R000000hDWF.jpeg

In the the NewExportEngine.log, the error message reads:
Exception in method: void com.Strategy.nee.PdfExporterApplication.main(String[]) with arguments: [[Ljava.lang.String;@14f232c4] org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'puppeteerService': Invocation of init method failed; nested exception is java.io.IOException: Cannot start up Puppeteer, error:
at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor.
postProcessBeforeInitialization(InitDestroyAnnotationBeanPostProcessor.java:139)…
 

Cause


This error may result if Node.js failed to upgrade while upgrading to Strategy Update 1. You can confirm this is the case by checking your install log.
If you see an error message that says something like, "Fail to copy node.exe to C:\Program Files (x86)\Common Files\Strategy\nodejs” generated, check that you have the correct Node.js version.
 

Action


To check if you have the correct Node.js version, perform the steps below:

  1. Open the directory C:\Program Files (x86)\Common Files\Strategy\nodejs\.
  2. Run node -v.
  3. The version should be v8.x.x.


If your version is not v8.x.x, first try repairing the installation. If this does not resolve the issue, you will need to perform a workaround.
 

Workaround


The easiest workaround is to manually install and configure the correct version of Node.js. To install and configure:

  1. From https://nodejs.org/dist/latest-v8.x/, download node-v8.16.0-win-x64.zip. 
  2. Extract the file.
  3. Open C:\Program Files (x86)\Strategy\Intelligence Server\PDFExportService\application.properties.
  4. Modify exporter.renderer.path to configure the downloaded Node.js. Double slashes are required. For example, exporter.renderer.path=C:\\Tools\\node-v8.16.0-win-x64\\node.exe
  5. Start the PDF Export service again. 

Comment

0 comments

Details

Knowledge Article

Published:

June 4, 2019

Last Updated:

September 22, 2022