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KB438481: FTP location invalid error due to "@" character within User Name / Password in MicroStrategy versions 10-10.6


Edgar Garcia Rosas

Senior Technical Account Manager I • MicroStrategy


SYMPTOM
While configuring an FTP device credentials, it is not possible to verify the credentials due to an "@" character in the username or password.
 
The the following error is encountered:


The FTP location is invalid.

 
CAUSE
This is an identified defect in Strategy Secure Enterprise Platform 10.x where the character “@” is used as a spliter between the user credentials and the FTP location.
 
For example  ftp://username:password@ftp.example.com/ThisIsTheFileName.pdf
 
-The login info is: username:password
-The actual file location is: ftp.example.com/ThisIsTheFileName.pdf.
 
If the username or password contains a '@,' we will split the URL in the wrong way. Hence it cannot deliver the file to FTP server successfully.
 
WORKAROUNDS
1.-Due user credential characters being translated to Hexadecimal, replacing the value of '@' with '%40' resolves the issue. For example:
 
Original:
Username: xxxx@xxx
Password: xx@xxxxxxx
 
After implementing workaround:
Username: xxxx%40xxx
Password: xx%40xxxxxxx
 
2.-Do not use the “@” character in the User Name or password.
KB319744: While configuring and verifying an FTP device, an error message of "FTP location is invalid" is returned due to "@" character in the password
 
KB319749: While configuring and verifying an FTP device, an error message of "FTP location is invalid" is returned due to the "Verify" button using previous settings.
 
 
ACTION
The issue is fixed in Strategy Secure Enterprise Platform 10.7 and beyond. KB438481


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Knowledge Article

Published:

December 19, 2017

Last Updated:

December 24, 2018