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KB440497: How to increase the PDF Export Engine rendering and resource timeouts in MicroStrategy Secure Enterprise 10.6 and later


Justin Parks

Principal Product Specialist • MicroStrategy


The following knowledge base article documents how to increase the rendering and/or resource timeout for the PDF Export Service in MicroStrategy 10.6 and newer.

SYMPTOM
When attempting to export to PDF using the PDF Export Engine in Strategy Secure Enterprise users may encounter the following errors on the PDF or within the NewExportEngine.log
 


Error: <message>
Rendering timeout: x seconds

or

Failed to open PDF template URL in x ms. Error Code: <error code>

CAUSE
These errors indicate that either the rendering timeout or resource timeout was hit during the export request. In some cases the failure may be due to some other error which caused these timeouts to occur first. These timeouts are separate from the more frequently encountered execution timeout. In most circumstances, they should not need to be modified. 
ACTION
In order to increase these timeouts, the application.properties file (<MSTR_HOME>\IntelligenceServer\PDFExportService\) needs to be modified to increase the value for the following two settings:
 

exporter.phantomjs.rendering.timeout = <value in seconds>
exporter.phantomjs.resource.timeout = <value in seconds>

In Strategy Secure Enterprise 10.6-10.9, there is a typo that needs to be corrected before this can take effect:
 

exporter.phantoms.rendering.timeout = 60
exporter.phantoms.resource.timeout = 60

Once the timeout values have been changed the PDFExport Service needs to be restarted for the changes to take effect.
  KB440497


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Knowledge Article

Published:

March 31, 2018

Last Updated:

August 15, 2019