Summary:
This Article describes a known issue when importing tables contaning columns with their name length above 32 characters. This issue can occur in Strategy 9.x and 10.x. The issue is specific to using Teradata data warehouse. This has not been reproduced by Strategy, but has occurred for multiple clients.
Symptom:
When importing a table containing a column length over 32 characters for any of its column names, the import will fail displaying the table.column could not be found. The name listed in the error message will show the letters truncated from the actual name of the table and column. The column will still show correctly in 'Show Sample Data', but it will not import.
Steps to Reproduce:
1. Create a table containing a column with a column name over 32 characters.
2. Import this table into Strategy from supported Teradata data warehouse.
Cause:
This is a limitation of the readSQL being used for reading column names while utilizing Teradata drivers.
Action:
Add a 'V' to the end of the FROM clause for the column readSQL resolves the issue.The new readSQL should look similar to 'FROM DBC.COLUMNSV'. This will allow the tables to import successfully. KB439418