SYMPTOM
In a prompted report, users click on the 'Next' button to select prompt answers which have a large number of elements and receive a timeout error in Strategy Web.
CAUSE
Timeout errors can occur when a prompt display requires more processing time if there are a large number of elements to display at one time. This is set with the 'Incremental fetch setting: Maximum number of attribute elements per block' setting in Preferences.
ACTION
Perform the following steps to alleviate this issue:
- Increase the server request time out. In the administrator page of Strategy Web, go to default properties for server, and increase "Request timeout" to a higher value.
- Lower 'Incremental fetch setting: Maximum number of attribute elements per block' in Preferences.
The Maximum number of attribute elements per block allows users set the maximum number of attribute elements that are displayed at one time when attribute element prompts, filter editors, or the Object Browser are used. Additional attribute elements are returned by clicking an incremental fetch icon. The default value is 30.
- Increase the JVM heap size.
The JVM Heap size is an allocation of memory for the Java Virtual Machine and it determines the amount of memory that the Java Virtual Machine in the Strategy Web Server can use.
To change this setting, open the registry of the Web Server machine and locate the following registry key.
\HKEY_LOCAL_MACHINE\Software\Strategy\JNI Bridge\ Configuration\JVM\Options\HeapSizeMax
WARNING:
Modifying registry values incorrectly may cause serious, system-wide problems that may require the re-installation of Microsoft Windows NT. Any edit of the registry is done at the user's own risk. Since these are user-initiated changes, they are not covered by any Strategy warranty. If using Microsoft Windows NT, the user should backup the registry and/or update an Emergency Repair Disk (ERD) prior to alterations.