SYMPTOM:
When running large reports in Strategy Office, the report errors out before completion and the following error message appears after a specific period of time:
The underlying connection was closed: An unexpected error occurred on a receive.
The MWSTracelog.txt contains an error similar to the following:
0x8004403B: java.rmi.RemoteException: getReportResults exception.; nested exception is:
com.Strategy.webservices.MWSException: <MWSErrorInfo><MWSErrorCode>0</MWSErrorCode><MWSErrorString>MWSExecution:GetReportResult failed[com.Strategy.web.objects.WebObjectsException: java.lang.IndexOutOfBoundsException: Index: 4, Size: 4
CAUSE:
This issue occurs because a connection between the client and server was broken before receiving the complete response.
ACTION:
Change the connection timeout setting to resolve this issue. To do this, perform the following steps: