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KB11682: "Unverifiable assembly 'MLLICSUP' failed policy check." error message appears when users attempt to access the MicroStrategy Web Server for the first time following an installation.


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"Unverifiable assembly 'MLLICSUP' failed policy check." error message appears when users attempt to access the MicroStrategy Web Server for the first time following an installation.

SYMPTOM:
 
Following the installation of Strategy 9.x, the first time a user attempts to hit the Strategy Web URL, they receive a "Server Error in '/Strategy' Application" error message. The unique portion of this message is in the Parser Error Message, illustrated below:
 

ka04W000000OgGWQA0_0EM4400000028zt.gif

 
Unverifiable assembly 'MLLICSUP' failed policy check.
Note: Reinstalling Strategy Web, the ASP.NET Framework and IIS has no effect on this error.
 
CAUSE:
 
This problem can occur if the process that is trying to access the Strategy Web application does not have all the proper permissions to do so. This issue can be resolved by taking some or or all of the following steps
 
ACTION:

  1. This issue can occur after Microsoft Sharepoint is installed on the Web Server machine. Additional configuration changes must be made for Microsoft Sharepoint and Strategy Web to coexist on the same server. For more information about how to configure MS Sharepoint in this scenario please go to Modifying Configuration Settings for an Application to Coexist with Windows SharePoint Services.
     
  2. Modify the web.config file located in the Web ASPx folder to force the trust level to be 'Full'. It is possibe that the trust tag may not be present in this file at first. In this situation, please add the trust tag within the <system.web> section of the file as noted below:
    <system.web>
    <compilation defaultLanguage="vb" debug="false" />
    <customErrors mode="Off" />
    .....
    <trust level="Full" originUrl=""/>
    .......
    </system.web>
  3. Make sure the ASPNET User account is not locked by going to the Computer Management applet located in Control Panel > Administrative Tools. From there go to 'Local Users and Groups' > 'Users', then go to the ASPNET User properties to make sure the account is not disabled. Sometimes the installation of Windows Security Patches and/or Hotfixes may cause this account to become disabled. The ASPNET user is used by the .Net worker process (aspnet_wp.exe in Windows 2000 or w3wp.exe in Windows 2003) to access the Web Application's files and resources.
     
  4. Make sure the ASPNET user account has full permissions to the following locations:
     
    1. C:\Program Files\Common Files\Strategy -- This folder houses all of the Jar files used by the Strategy Web application.
    2. C:\Program Files\MicroStrategy\Web ASPx
  5. Finally, make sure the ASPNET user is not a member of a group that has a lower amount of permissions, for example, the local 'Users' or 'Guests' group.

Third Party Software Installation
WARNING:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability.
 


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Knowledge Article

Published:

June 16, 2017

Last Updated:

June 16, 2017