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KB13082: ‘The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c) Network problem, or d) Server reached maximum connection limit’ error is seen every 5 minutes in the Web Errors log in MicroStrategy Web


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• Strategy


Get connection failed error every 5 minutes in the Web log

SYMPTOM:
 
In the Web Errors log, the following error will sometimes appear every five minutes:
<record>
<package>com.Strategy.webapi</package>
<level>SEVERE</level>
<miliseconds>1134115445122</miliseconds>
<timestamp>12/09/2005 00:04:05:122</timestamp>
<thread>3</thread>
<class>CDSSXMLClusterNode</class>
<method>CreateConnection</method>
<message>
The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c) Network problem, or d) Server reached maximum connection limit.
CAUSE:
 
This error occurs because at least one unconnected server on the Web Administrator page is still set to 'Automatically connect to Intelligence Server when Web Server or Intelligence Server is restarted,' but Strategy Web does not have access to it. Every five minutes, Strategy Web 8.x checks the unconnected servers list to see if any servers are set to automatically connect. For each one it finds, it attempts to connect to the server. If unsuccessful, the above error will be logged.
 
ACTION:
 
To resolve these errors, perform one of the following actions:

  1. In the Web Administrator -> Servers page, make sure all unconnected servers are set to 'User manually connects Web to Intelligence Server.'
  2. Delete unused servers from the unconnected servers list.
  3. Re-enable access to any unconnected servers.

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Knowledge Article

Published:

April 6, 2017

Last Updated:

April 6, 2017