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KB13117: Project Merge fails with error ‘Failure to communicate with MicroStrategy Intelligence Server’ in MicroStrategy Administrator


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• Strategy


This article outlines why a Project Merge fails with the error ‘Failure to communicate with MicroStrategy Intelligence Server’

SYMPTOM:
When running a Project Merge involving a 3-tier project source, Project Merge fails to complete and the following error occurs:

ka04W000000Oc1uQAC_0EM440000002HXS.jpeg

The following error has occurred and is not recoverable. Once this message box is closed, Project Merge Wizard will close. Network: Failure to communicate with Strategy Intelligence Server.
CAUSE:
This issue occurs because Project Merge has reached a limit on 'User session idle time', a governing setting in the Strategy Intelligence Server  Configuration.
 
When Project Merge is run in a 3-tier environment, two connections are made on Strategy Intelligence Server  as shown below:
 

ka04W000000Oc1uQAC_0EM440000002HXL.jpeg

The first connection is an active connection to the project and the second is a general connection to the Strategy Intelligence Server  machine. These connections are created first when a user logs into the project source via the Project Merge Wizard, and second when Project Merge begins to gather information from the project in the project source. These connections stay active until the command is sent to save objects into the metadata, as shown below:
 

ka04W000000Oc1uQAC_0EM440000002HXN.jpeg

 
During this time, the connections on the Strategy Intelligence Server are idling. If the 'User session idle time' is reached during one of these points, the connection will be cut and Project Merge will display the error shown above.
 
NOTE: There is nothing in the Project Merge logs to indicate that anything has gone wrong. This log abruptly stops after a few objects in the 'Saving schema objects into metadata' section with no error recorded. However, the following pair of lines is repeated in the DSSErrors.log:
 
2005-12-08 13:24:17.803-05:00 Network: Not Connected to Strategy Intelligence Server.
2005-12-08 13:24:17.818-05:00 Network: Failure to communicate with Strategy Intelligence Server.
WORKAROUND:
To workaround this issue, simply increase the User Session Idle time that is located in the Strategy Intelligence Server Configuration under the General Governing settings, as shown below:
 

ka04W000000Oc1uQAC_0EM440000002HXM.jpeg

 
One way to access these settings is to right-click on an active 3-tier project source and select 'Configure Strategy Intelligence Server'. Another way to access these settings is to Select Administration -> Server -> Configure Strategy Intelligence Server. Once into the General Governing Settings, there is a parameter that is labeled, 'User session idle time (sec)'.
 
If modifying this setting is not possible, Project Merge may also be performed in 2-tier environments.
 


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Published:

May 29, 2017

Last Updated:

May 29, 2017