SYMPTOM:
Users may find that the Strategy Intelligence Server 9.x process hangs on startup when the machine is started with the /userva switch specified to some value less than 3000 in the boot.ini file.
CAUSE:
Strategy Intelligence Server 9.x, on startup, reads the contents of the boot.ini to check whether the machine is set up in 4GT mode. If this is the case, it will attempt to scan all the 3GB of memory space to ensure that this is available.
The /userva switch is a new option introduced by Microsoft that allows users to tune the amount of virtual memory available to application processes between 2GB and 3GB when the 4GT mode is enabled. For example, setting this as /userva=2800 will allow Microsoft Windows to allocate only 2.8GB to user processes.
Since current versions of the Strategy Intelligence Server are not aware of this switch, they will attempt to access memory addresses beyond the limits that Windows will allocate because of this switch. This results in the hanging of the process.
ACTION:
Users facing this issue should remove the /userva switch from the machine boot.ini file and reboot the machine to allow Strategy Intelligence Server 9.x to start. This issue is currently under investigation. Contact Strategy Technical Support for an update on the status of this issue.
For further details, refer to the following Microsoft Knowledge Base technical note:
How to use the /userva switch with the /3GB switch to tune the User-mode space to a value between 2 GB and 3 GB
Third Party Software Installation:
WARNING:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability.