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KB14684: Report execution fails with error ‘Results for this message cannot be retrieved from MicroStrategy Intelligence Server. This might be because the execution has failed. Please contact your administrator’ in MicroStrategy Web.


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• Strategy


Symptom

When executing a report in Strategy Web, execution fails.
Error in report results:

Your request could not be processed. Please try again. If the problem persists, contact the Administrator. (Results for this message cannot be retrieved from Strategy Intelligence Server. This might be because the execution has failed. Please contact your administrator.)

 
The web log on the web server machine contains following error:
<method>GetExecutionResultsEx</method><message>(Results for this message cannot be retrieved from Strategy Intelligence Server. This might be because the execution has failed. Please contact your administrator.) (com.Strategy.webapi.MSTRWebAPIException)</message><exception>com.Strategy.webapi.MSTRWebAPIException: (Results for this message cannot be retrieved from Strategy Intelligence Server. This might be because the execution has failed. Please contact your administrator.)

The DSSErrors.log file on the Strategy Intelligence Server machine contains the following errors:
MsiWorkingSet::PersistMsg(): failed to attach RI to msg, error 0x80003F79CDSSServerMessage::put_OriginalRI: WSResultPool->AddRI for msg xxxx return error 0x80003F79CDSSServerMessage::put_OriginalRI: WSResultPool->AddRI for msg xxxx return error 0x80003F79CDSSServerMessage::GetReportInstance(): get_OriginalRI() return error 0x1

Cause

The size of the report that was to be executed has 400MB report cache size while 'Maximum RAM for Working Set cache size' is set as 102400KB, as shown in the image below:

ka04W000000OfIhQAK_0EM44000000WZwI.png

 
The Strategy Intelligence Server was unable to swap out the report instances of 40MB in the Working Set.
For more information about how Working Set setting governs Strategy Web report execution and why a report instance (RI) sometimes cannot be swapped to disk, refer to the following Strategy Knowledge Base technical notes:
KB8621 - User request is completed. Maximum memory usage has been reached for existing objects." error message is received by users in Strategy Web.
KB8617 - What is the 'Working Set' governor setting which is available in Strategy Intelligence Server 9.x?

Action

Increase the size of Maximum RAM for Working Set cache to a higher value. Depending on the resources available and the version installed, please set the Maximum working set RAM to a number between the following list:

  • Before Strategy 9.5, the maximum limit is 64GB (65536 MB) for both Windows 32 bit and 64 bit. 
  • On Strategy 10.x the limit is 2 TB (2097152 MB).

WARNING: Increasing the 'Maximum RAM for Working Set cache' setting will increase the possible limit amount of RAM that can be used by the Strategy Intelligence Server. Setting this to a higher limit does not mean the memory will be set aside for immediate use by the Strategy Intelligence Server. However, if needed, that limit is available, in the same way, the Maximum RAM for cache settings behave.


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Details

Knowledge Article

Published:

March 29, 2017

Last Updated:

August 24, 2022