SYMPTOM:
In Strategy Intelligence Server Universal 9.4.1 and above, a red 'x' may appear instead of an image when exporting Report Services Documents to PDF in Strategy Web. Users may notice that exporting from Strategy Developer displays images properly for these cases.
CAUSE:
This issue occurs because the path specified for the image is incorrect when considered relative to the Intelligence Server Universal location.
For correct display of images, the images must be available to both the Strategy Intelligence Server and to the client - Strategy Desktop - when designing the document. If the designers do not have access to the image, they will be unable to see the image while creating the document. In the Intelligence Server cannot access the image when exporting, no image will be present in the exported Document.
ACTION:
To ensure that the image is available to both products as needed, use any of the following in the Image Source property:
For example, if the image is on a Web server machine, users can specify the URL for the file as long as Strategy Intelligence Server and users who design the documents can access that location. Once the location is established and the image file is available in that location, users can insert the image into a document.
NOTE: Users should be able to find the path and file name of images to use by viewing the source of a Web page.
The following types of images should be used in order to display an image correctly via PDF view:
Follow the steps below in order to insert an image in a document:
Images/myimage.jpg
To correctly allow the Intelligence Server Universal obtain the image, the images folder on the web server should have the correct permissions to enable access to the image from the Intelligence Server.