EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB16985: Subscribing report appears in the History List, but when a user runs same report from the report folder in MicroStrategy Web, and then the History cache is not hit and no report cache is created


Community Admin

• Strategy


Several reports have been under subscription by some users. The subscribing reports appear in their History List, and then those History caches are created successfully. But when the users run same reports from report folder, the History caches are not hit and no report caches are created in MicroStrategy Web.

SYMPTOM:
Several reports have been under subscription by some users. The subscribing reports appear in their History List, and then those History caches are created successfully. But when the users run same reports from report folder, the History caches are not hit and no report caches are created in Strategy Web.
CAUSE:
The users do not have the 'Use Server Cache' privilege under common privileges in Project Access. Any users who need to create and use server cache must have 'Use Server Cache' privilege. Logically, report cache and history cache are treated separately.
The history caches are not hit when the users run the reports from report folder. This is expected behavior. The users without 'Use Server Cache' privilege cannot create report caches or use existing report caches when the users run the reports from report folder in Strategy Web 8.x.
ACTION:
To resolve this issue, the administrator must grant the users 'Use Server Cache' privilege under common privileges in Project Access. Follow the steps below:

  • Launch Strategy Desktop 8.x and login as administrator.
  • Go to 'Administration' > 'User Manager' and open the user in edit mode in the User Editor.
  • In 'Project Access', find '4.Common Privileges'.
  • Grant the users 'Use Server Cache'.
  • Save the changes.
ka04W000000OdnGQAS_0EM4400000028iI.gif

Comment

0 comments

Details

Knowledge Article

Published:

June 15, 2017

Last Updated:

June 15, 2017