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KB17194: 'Connection Dead' error message appears when performing a data load in MicroStrategy Enterprise Manager 10.x


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• Strategy


SYMPTOM:
During a Strategy Enterprise Manager 10.x data load, a 'Connection Dead' error occurs and the data load fails. Examining the MSTRMigration.log at the time of the error reveals the following:
 


Error executing SQL :Execute Query failed. Error type: Odbc error. Odbc operation attempted: SQLExecDirect. Connection Dead.

An addition 'not connected to' error may occur if the EM_LOG is being used:
 

Error updating EM_LOG : Error executing SQL :End transaction. failed. Error type: Odbc error. Odbc operation attempted: SQLTransact. Option: SQL_ROLLBACK. DATABASE_CODE: not connected to DATABASE_TYPE

For example, when using the DataDirect ODBC Wire Protocol driver to connect to a Strategy Enterprise Manager 9.x warehouse on an Oracle server the MSTRMigration.log file will look like:
 

10/25/2007 8:11:01 AM Error executing SQL :Execute Query failed. Error type: Odbc error. Odbc operation attempted: SQLExecDirect. Connection Dead.
10/25/2007 8:11:01 AM Error updating EM_LOG : Error executing SQL :End transaction. failed. Error type: Odbc error. Odbc operation attempted: SQLTransact. Option: SQL_ROLLBACK. ORA-03114: not connected to ORACLE

 
CAUSE:
The error occurs because the execution time for the SQL statement exceeded the maximum allowed 'idle' connection time for the network and OS.
 
ACTION:
Follow the steps below to resolve this issue:
 

  1. Ensure that all firewalls are either turned off or that the correct access through the firewall is set.
  2. Configure the KeepAliveTime registry setting to a reasonable value, Microsoft recommends five minutes.
    According to Microsoft Knowledge Base article 324270 (http://support.microsoft.com/kb/324270):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
    Value name: KeepAliveTime
    Key: Tcpip\Parameters
    Value Type: REG_DWORD-Time in milliseconds
    Valid Range: 1-0xFFFFFFFF
    Default: 7,200,000 (two hours)

    This value controls how frequently TCP tries to verify that an idle connection is still intact by sending a keep-alive packet. If the remote computer is still reachable, it acknowledges the keep-alive packet. Keep-alive packets are not sent by default. You can use a program to configure this value on a connection. The recommended value setting is 300,000 (5 minutes).

 
Registry Modification:
WARNING:
Modifying registry values incorrectly may cause serious, system-wide problems that may require the re-installation of Microsoft Windows NT. Any edit of the registry is done at the user`s own risk. Since these are user-initiated changes, they are not covered by any Strategy warranty. If using Microsoft Windows NT, the user should backup the registry and/or update an Emergency Repair Disk (ERD) prior to alterations.
 
Third Party Software Installation:
WARNING:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability.
 


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Knowledge Article

Published:

April 5, 2017

Last Updated:

April 5, 2017