EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB17470: The DSSErrors log and other diagnostics logs created by the MicroStrategy Intelligence Server stop being written to if a database connection used ina database instance is set to use a ‘Multi-threaded’ database driver mode


Community Admin

• Strategy


The DSSErrors log and other diagnostics logs created by the MicroStrategy Intelligence Server 10.x stop being written to if a database connection used ina database instance is set to use a ‘Multi-threaded’ database driver mode

SYMPTOM:
Users may notice that their DSSErrors logs are written to on Strategy Intelligence Server 10.x startup and shortly after that the logs stop being updated. Other diagnostic logging turned on for the "CastorServer Instance" also stops being appended to log files at about the same time.
 
On closer observation it may be seen that the logs stop being written when jobs start executing against the database.
 
CAUSE:
This issue has been identified as a code level issue with Strategy Intelligence Server 10.x logging architecture that is triggered when a database connection is set to use the 'Multi-threaded' database driver mode in the database connection settings as shown in the screenshot below:
 

ka04W000000OdifQAC_0EM440000002BPN.jpeg

 
ACTION:
Database connections should always use the 'Multi-process' mode for the database driver mode. Refer to the following Strategy Knowledge Base technical note for more information:
 
KB8932 (KB5300-7XX-0425): What is the recommended setting for the ODBC Database Driver Mode in Strategy Intelligence Server?
 
Setting the database connection setting back to 'Multi-process' will resolve this issue and also provide the additional robustness associated with the multi process mode of operation.
Strategy will continue to investigate and post updates as soon as they are available.
 
 


Comment

0 comments

Details

Knowledge Article

Published:

June 20, 2017

Last Updated:

June 20, 2017