SYMPTOM:
Large reports and Report Services documents which contain many dataset / large datasets may fail with a "Process Hung" error. Below are two common error messages as they appear in the DSSErrors.log:
MultiProcess] Quiting child process because of error: Cannot execute command because there was a hang
Database Classes] Unknown failed. Unable to connect. Error type: System call error. Error communicating with connection process. Process hung..
CAUSE:
Although the errors are generic, when the Strategy Intelligence Server 8.x is under high stress the issue can be linked to performance / resource issues. This is most notable when the Strategy Intelligence Server metadata and the data warehouse reside in the same location, while sharing the same Data Source Name (DSN) on the Strategy Intelligence Server machine. The following Strategy Knowledge Base technical note provides more details on resource related errors and some basic troubleshooting for them:
KB19157 (KB5300-8X-2889): "System call" errors are found in the DSSErrors.log file on a Strategy Intelligence Server 9.x and newer machine
The error is also often only seen when the physical machine where the database resides is also under heavy load.
ACTION:
Strategy Technical Support suggests that the data warehouse and the Strategy Intelligence Server metadata reside in different database locations to help minimize resource contention issues.
WORKAROUND:
In a small number of cases, using separate Data Source Names (DSN) for the data warehouse and the metadata, even though they are pointing to the same databsae, has helped alleviate the issue.