EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB18789: "MSIXML: Server name not initialized" error messages are logged multiple times in the Web Log in MicroStrategy Web 9.x


Community Admin

• Strategy


This article explains the reason of some errors that can be seen in the Web Log if MicroStrategy Intelligence Server's connected mode is set to 'Automatically connect to Intelligence Server when Web Server or Intelligence Server is restarted.'

SYMPTOM:
The following 'MSIXML: Server name not initialized' error messages are logged multiple times in Web Log. The Web log easily gets full with this error message.


<record> 
  <package>com.Strategy.webapi</package> 
  <level>SEVERE</level> 
  <miliseconds>1211182702671</miliseconds> 
  <timestamp>05/19/2008 16:38:22:671</timestamp> 
  <thread>4</thread> 
  <class>CDSSXMLClusterNode</class> 
  <method>CreateConnection</method> 
  <message>MSIXML : Server name not initialized. (com.Strategy.webapi.MSTRWebAPIException)</message> 
  <exception>com.Strategy.webapi.MSTRWebAPIException: MSIXML : Server name not initialized 
 at com.Strategy.webapi.CDSSXMLClusterNode.CreateConnection(Unknown Source)
  at com.Strategy.webapi.CDSSXMLClusterNode.InitConnection(Unknown Source)
  at com.Strategy.webapi.CDSSXMLAdmin.AddDSSXMLClusterNode(Unknown Source)
  at com.Strategy.webapi.CDSSXMLAdmin.InitConnection(Unknown Source)
 at com.Strategy.webapi.CDSSXMLAdmin.Connect(Unknown Source)
 at com.Strategy.web.objects.WebClusterAdminImpl.connect(Unknown Source)
 at com.Strategy.web.admin.beans.AdminServersHelper.connectIServers(Unknown Source)�! D;
 at com.Strategy.web.admin.beans.AdminServersHelper$ServerConnectionsUpdateTask.run(Unknown Source)
 at java.util.TimerThread.mainLoop(Unknown Source)
 at java.util.TimerThread.run(Unknown Source)
</exception>
  <userName>unavailable</userName> 
  <clientID>unavailable</clientID> 
</record>

 

CAUSE:
One of the causes for this error message logged in Web Log is when there is any unnecessary Strategy Intelligence Server name listed in Web Administrator page and also the Strategy Intelligence Server's connected mode is set to 'Automatically connect to Intelligence Server when Web Server or Intelligence Server is restarted.' Strategy Web periodically tries to look for the connection to unconnected servers when this option is selected. Hence, if there is any unreachable Strategy Intelligence Server listed, the Web Server throws the error message above.
 
ACTION:
Remove any Strategy Intelligence Server listed under 'Unconnected Servers' if it is not used, as shown below:

  • Click Modify for Unconnected Servers, as shown below:
ka04W000000OgfGQAS_0EM4400000028Yk.jpeg
  • Click Delete, as shown below:
ka04W000000OgfGQAS_0EM4400000028Yi.jpeg

Comment

0 comments

Details

Knowledge Article

Published:

June 13, 2017

Last Updated:

June 13, 2017