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KB18882: ‘You do not have sufficient permission to access the resource you requested.’ error occurs when accessing the 'My Subscriptions' page in MicroStrategy Web


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Article outlines why the error ‘You do not have sufficient permission to access the resource you requested.’ error occurs when accessing the 'My Subscriptions' page in MicroStrategy Web.

SYMPTOM:
When a user accesses the 'My Subscriptions' page in Strategy Web, the following error messages are seen and no History List subscriptions are visible:
 

ka04W000000Of5fQAC_0EM4400000028Yg.jpeg

 
Error in My Subscriptions
You do not have sufficient permission to access the resource you requested. If the problem persists, please contact the Strategy Server Administrator.
Subscriptions
An error has occurred on this page.
You do not have sufficient permission to access the resource you requested. If the problem persists, please contact the Strategy Server Administrator.
In addition, the following message can be seen in the Strategy Weblogs:
 
(The user does not have Browse access to this Schedule Trigger object (ID is 'XXX')
CAUSE:
The user does not have Browse permissions for one of the schedules in the user's History List subscriptions.
NOTE: Other possible causes for this error message can be found in the following Strategy Knowledge Base technical notes:
 

  • KB10619 - "You do not have sufficient permission to access the resource you requested." error message appears when a Strategy Web 8.x user navigates to the subscriptions page.
  • KB15444 - 'Error in My Subscriptions. You do not have sufficient permission to access the resource you requested' error occurs when trying to access the Subscriptions folder in Strategy Web 8.1.x

ACTION:
Follow the steps below to resolve this issue:
 

  • Run the following SQL against the Strategy Metadata to determine the schedule with incorrect permissions, replacing <prefix> with the appropriate metadata prefix and <objectid> with the object ID from the Strategy Web log error:
    SELECT OBJECT_NAME FROM <prefix>DSSMDOBJINFO WHERE OBJECT_ID = '<objectid>'
  • In Strategy Desktop 8.x, expand the Administration icon.
  • Access the Schedule Manager.
  • Right-click on the appropriate schedule, from Step 1, and select 'Properties'.
  • On the 'Security' tab, make sure the user is either explicitly listed or belongs to a group listed which has been granted 'View' access on the ACL, or if a custom ACL is used, the 'Browse' permission, as shown below:
ka04W000000Of5fQAC_0EM4400000028Yf.jpeg

NOTE: By default, all new schedules are created with 'View' permissions for the Everyone group.
 


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Knowledge Article

Published:

June 8, 2017

Last Updated:

June 8, 2017