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KB19587: Intermittent error: “System call error. Error communicating with connection process. Find target process dead while waiting for reply” occurs when connecting to a Teradata database from MicroStrategy Developer


Stefan Zepeda

Salesforce Solutions Architect • Strategy


Intermittent error: “System call error. Error communicating with connection process. Find target process dead while waiting for reply” occurs when connecting to a Teradata database from MicroStrategy Developer

SYMPTOM:
When running a report from Strategy, either in two-tier Developer mode, or through the Strategy Intelligence Server, accessing a Teradata database through an ODBC connection, users may encounter the following error:
 
Error: System call error. Error communicating with connection process. Find target process dead while waiting for reply.

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SQL Generation Complete. QueryEngine encountered error. Unknown failed. Unable to connect. Error type: System call error. Error communicating with connection process. Find target process dead while waiting for reply. Error in Process method of component: QueryEngineServer, Project Delivery Data Mart, Job 6783, Error Code=-2147212544
Additionally, when connecting to the Teradata warehouse using the Test ODBC tool, the following error may be seen:
 
Connection Error:
Error connecting to DSN:
Unknown failed. Unable to connect. Error type: System call error.
Error communicating with connection process. Failed to read from pipe.
System Error (0): Success.
CAUSE:
This intermittent error is likely the result of an incorrect DSN / network configuration for some database nodes. This results in the Strategy multiprocess component being unable to create a connection to the Teradata warehouse occasionally.
 
For Teradata there are two potential related causes for this issue:
 

  1. In the ODBC driver connection, the Teradata ODBC driver allows users to specify more than one host/IP address for the server information (DBCName, DBCName2 etc.). The ODBC driver may pick any of the servers to connect to at random. If any of the host names / IP addresses specified are no longer valid, this issue may occur.
     
    For additional information, refer to the following Strategy Technical document:
    KB3100-000-0013 - ‘Error communicating with connection process. Find target process dead while waiting for reply` error occurs when running reports in Strategy 8.x against Teradata database.
     
  2. For Teradata databases, users may specify one or more aliases for a database with each IP addresses aliased as <hostname>cop1, <hostname>cop2 etc. in the network, or in the machine 'hosts' file. When the ODBC driver attempts to connect to a host specified in the driver configuration, and this connection attempt fails, the ODBC driver will then attempt to connect to <hostname>cop1, <hostname>cop2 etc in that order. If more than one Teradata node/host is inaccessible this action may run beyond the timeout that the Strategy multiprocess component will wait for, and this error may be seen.

ACTION:
Users should verify the ODBC DSN configuration details and network setup, removing any invalid entries, and or restarting any inaccessible database nodes. Users may contact Strategy Technical Support for assistance identifying the root cause of this issue.
 


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Knowledge Article

Published:

June 2, 2017

Last Updated:

June 2, 2017