SYMPTOM:
When running a report from Strategy, either in two-tier Developer mode, or through the Strategy Intelligence Server, accessing a Teradata database through an ODBC connection, users may encounter the following error:
Error: System call error. Error communicating with connection process. Find target process dead while waiting for reply.

SQL Generation Complete. QueryEngine encountered error. Unknown failed. Unable to connect. Error type: System call error. Error communicating with connection process. Find target process dead while waiting for reply. Error in Process method of component: QueryEngineServer, Project Delivery Data Mart, Job 6783, Error Code=-2147212544
Additionally, when connecting to the Teradata warehouse using the Test ODBC tool, the following error may be seen:
Connection Error:
Error connecting to DSN:
Unknown failed. Unable to connect. Error type: System call error.
Error communicating with connection process. Failed to read from pipe.
System Error (0): Success.
CAUSE:
This intermittent error is likely the result of an incorrect DSN / network configuration for some database nodes. This results in the Strategy multiprocess component being unable to create a connection to the Teradata warehouse occasionally.
For Teradata there are two potential related causes for this issue:
ACTION:
Users should verify the ODBC DSN configuration details and network setup, removing any invalid entries, and or restarting any inaccessible database nodes. Users may contact Strategy Technical Support for assistance identifying the root cause of this issue.