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KB20241: “The results for this report are no longer available.” error occurs when accessing a History List message in a cluster while one of the MicroStrategy Intelligence Server 9.x and 10.x nodes is restarting due to memory depletion


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“The results for this report are no longer available.” error occurs when accessing a History List message in a cluster while one of the MicroStrategy Intelligence Server 9.x and 10.x nodes is restarting due to memory depletion

SYMPTOM:
In a Strategy Intelligence Server 9.x and 10.x clustered environment, if a report is sent by to History by Node A for which no cache files already exists; a cache file is created on Node A. If the node A then restarts due to memory depletion the cache file will be unavailable. During this time, if the History List message is accessed from another node, say Node B, the following message will occur:
 



 

The results for this report are no longer available. Possible reasons are a) History List message results are unavailable, b) Insufficient privileges for executing multiple reports simultaneously, or c) the Working Set has reached the maximum number of reports.

However, even after Node A is brought back online the error still occurs. If the report is re-run as prompted by the error message it does in fact successfully hit the cache file.
 
CAUSE:
The error is expected after Node A was stopped. This is because when a cache file is created by one node in a clustered environment, and then this node is shutdown normally, the cache cannot be hit until the server is started again. This is by design.
 
The design is that when a node shuts down normally it signals the other nodes in the cluster that it is shutting down and that they should not try to access it; this includes accessing cache files held by node A. If however the node shuts down unexpectedly, it is unable to send this message and the other nodes will still attempt to access the cache file. Depending on how the cache sharing is configured this may or may not result a successful read of the cache file.
 
Considering this logic the error message as described by the Symptom should occur under the first condition. However, if the node comes back up the History List message should successfully hit the cache. If the History List message was never accessed while Node A was down, it will successfully display the report contents. However, once the error has been encountered the status of the History List message will forever be marked as an ‘Error’ and will always return the error message. This is a known issue with Strategy Intelligence Server 8.x.
 
ACTION:
 
Strategy will continue to investigate and post updates as soon as they are available.
 
 
WORKAROUND:
After the node containing the cache files comes back online, resend the report to History. Since the cache file is now available, when the report is sent to history it will hit the cache and not execute against the warehouse (assuming that nothing has changed to invalidate the cache). After the new History List message is created, delete the original.
 


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Published:

May 26, 2017

Last Updated:

May 26, 2017