EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB229967: "The source project 'Enterprise Manager' is using an older version. Use the Configuration Wizard to update the project to the current version before moving it" error message appears when configuring a new Enterprise Manager 9.5.0 project


Community Admin

• Strategy


Error message appears when configuring a new Enterprise Manager 9.5.0 project

 
SUMMARY
This technical note describes an issue where the version of the Access file containing the Enterprise Manager project in Strategy 9.5.0 is not updated to version 9.5.0 and results in an error during initialization.
 
SYMPTOM
An error message is received when configuring a new Enterprise Manager project in Strategy Enterprise Manager 9.5.0
 

ka04W000000OhZNQA0_0EM4400000029Gg.jpeg

 


The source project 'Enterprise Manager' is using an older version. Use the Configuration Wizard to update the project to the current version before moving it

 
CAUSE
This is a known issue in Strategy Enterprise Manager 9.5.0. The Access file containing the Enterprise Manager project is out of date and needs to updated.
 
ACTION
One of the following options can be used to fix this issue.
Option 1:  Upgrade using Configuration Wizard
This option will requires the Strategy Intelligence Server to be temporarily pointed to the out-of -the-box Enterprise Manager Metadata.  
1) Create a DSN that connects to the Strategy 9.5 (9s) out of the box Enterprise Manager Metadata. This is a Microsoft Access file called "EM_Proj_MD.mdb" and located at: "<install_drive>:\Program Files (x86)\Strategy\Enterprise Manager"
2) Open Strategy Configuration Wizard and select "Configure Intelligence Server".
3) Select the DSN created in step 1 and click "Next".
4) Leave the default username and password and click "Next".
5) Select "Use the selected Server Definition as active" and click on the "Enterprise Manager default" Server Definition. Click "Next".
6) Continue clicking "Next" keeping all the default settings and click "Finish". Once this process is completed, the Intelligence Server will be pointing to the out of the box Enterprise Manager Metadata.
7) Once the process is completed, the Configuration Manager main screen will be displayed. Select the option for "Upgrade Existing Environment to Strategy Analytics Enterprise".
8) Select "Intelligence Server Components". Click "Next".
9) Leave the default username and password and click "Next"
10) Check the following options and click "Next":
     - Upgrade Metadata Repository (Required)
     - Execute Project Logical Upgrade

ka04W000000OhZNQA0_0EM4400000029Gi.jpeg

11) Modify the ExtendedAnsiSQL and MaxBufferSize advanced settings in the ODBC Administrator as per KB20459 and click "Ok" in the popup window. 
12) Click "Finish" to start the Upgrade process. 
 
Once the process has been completed, the Enterprise Manager 9.5 (9s) Metadata file should be already upgraded and the project transfer in the Enterprise Manager Console Initialization should no longer display an error message.
The Intelligence Server can now be pointed to any desired Metadata by using Configuration Wizard.
 
 
Option 2: Upgrade using Strategy MDUpdateUtil Tool
1) Create a DSN that connects to the Strategy 9.5 (9s) out of the box Enterprise Manager Metadata. This is a Microsoft Access file called "EM_Proj_MD.mdb" and located at: "<install_drive>:\Program Files (x86)\Strategy\Enterprise Manager".
2) Navigate to the "EM_Proj_MD.mdb". Right click on it and select "properties". Uncheck the option for "Read Only" and click "Ok".
3) Open Strategy Developer and create a 2-tier Project Source to connect to the Enterprise Manager Metadata using the DSN created in Step 1.
4) Run the Strategy MDUpdateUtil Tool. This can be found under: "<install_drive>:\Program Files (x86)\Common Files\Strategy"
5) Select the name of the Project Source created in Step 3 from the drop down list and click "Next>>>".
6) Check the following upgrade options and click "Update":
     - Update System Objects and Translations (in both Configuration and Projects Sections).
     - Update Report and Document Definitions (in Projects Section only)

ka04W000000OhZNQA0_0EM4400000029Gd.jpeg

7) Once the upgrade process has been completed, close all widows and exit the Strategy MDUpdateUtil Tool.
 
At this point, the Enterprise Metadata 9.5 (9s) Metadata file should be already upgraded and the project transfer in the Enterprise Manager Console Initialization should no longer display an error message.
 
 
Option 3: Contact Strategy Technical Support
It is possible to contact Strategy Technical Support to request an upgraded version of the Enterprise Manager 9.5 (9s) Metadata file. Contact Strategy Technical Support to get a copy of the upgraded Enterprise Manager 9.5 (9s) Metadata.
 
The Strategy Internal Reference Number for the issue discussed in this technical note is 1014426.


Comment

0 comments

Details

Knowledge Article

Published:

May 15, 2017

Last Updated:

May 15, 2017