EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB249428: "[ODBC driver for Oracle][Oracle] Error while trying to retrieve text for error ORA-01019" error message occurs when opening Warehouse Catalog for the first time in MicroStrategy Developer 9.4.1


Stefan Zepeda

Salesforce Solutions Architect • Strategy


This technical note outlines why "[ODBC driver for Oracle][Oracle] Error while trying to retrieve text for error ORA-01019" error message occurs when opening Warehouse Catalog for the first time in MicroStrategy Developer 9.4.1.

SYMPTOM:
After installing Strategy 9.4.1 on a new machine, users may encounter the following error message when attempting to open the Warehouse Catalog in Strategy Developer:

ka02R000000kckWQAQ_0EM440000002C50.jpeg

 
 


An error was detected while trying to read the Warehouse catalog:
Database error <>: Connect failed.
Error type: Odbc error. Odbc operation attempted: SQLDriverConnect. [NA000:1019: on SQLHANDLE][Microsoft][ODBC driver for Oracle][Oracle] Error while trying to retrieve text for error ORA-01019 [IM006:0: on SQLHandle] [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed [IM006:0: on SQLHANDLE][Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed [01000:0: on SQLHANDLE][Microsoft][ODBC Driver Manager] The driver doesn't support the version of ODBC behavior that the application requested (see SQLSetEnvAttr). 
Do you want to modify the Warehouse Catalog Browser options to try solve this problem?
Please re-run the Warehouse Catalog Browser after you make your changes.

 
CAUSE:
This issue occurs when there are multiple 32-bit client libraries (SQAORA32.dll) on the same machine. When the Strategy application attempts to communicate with the driver, the application does not know which libraries to use, hence the error occurs.
 
ACTION:
Remove the extra 32-bit client library from the client machine. If the issue occurs in a 3-tier connection, the extra library should be removed from the Intelligence Server machine.
 
Third Party Software Installation Warning:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability.


Comment

0 comments

Details

Knowledge Article

Published:

March 31, 2017

Last Updated:

March 31, 2017