SYMPTOM:
In Strategy Web 10.0, users can use Edit Links in a Report Services Document to navigate to another report or document and answer prompts on the target object dynamically, depending on the element clicked on to execute the link. However, if the element starts with a leading space character, when linking, the space is replaced with “nbsp;” in the target. Thus, the target report prompt will not match any answers and the report will show:
"No data returned for this view. This might be because the applied filter excludes all data".

After clicking on the Edit Link to navigate to the target, the space character is lost and the prompt is answered with an incorrect element, causing no data to be returned:

STEPS TO REPRODUCE:
CAUSE:
This is an identified defect in Strategy Web 10.0.
ACTION:
This issue has been addressed in Strategy version 10.1. Please upgrade to take advantage of the fix.
WORKAROUND:
This issue does not occur when using URL API. For more information on passing prompt answers refer to tech note KB45965 .