SYMPTOM
When running Strategy Analytics Enterprise 9.4.1 on Linux, users may notice that the memory of the Intelligence Server process constantly increases. The rate at which this happens will vary by environment and depend on usage.
When enabling performance counters per KB19155: Recommended performance logging counters to enable when troubleshooting memory or performance issues in MicroStrategy Intelligence Server Universal 9.x in UNIX environments , it will be seen that "Total cached memory (KB) in the server process heap" will be extremely high whereas usage of this memory recorded in "Total in-use memory (KB) in server process heap" will be low.
CAUSE
The issue is caused by a known issue in SmartHeap when running the Strategy Intelligence Server 9.4.1 as a service on Linux. The cached memory sub pools created by SmartHeap will not be shared between threads resulting in the total amount of cached memory constantly growing.
For more details on SmartHeap, refer to KB16977: What is SmartHeap and how does it work with the MicroStrategy Intelligence Server 9.x?.
WORKAROUND
The issue only occurs when running the Strategy Intelligence Server 9.4.1 as a service. Running the Strategy Intelligence Server 9.4.1 as an application will not exhibit these symptoms as the SmartHeap sub pools will be limited to 1MB. The only side-effect of this change will be that the Intelligence Server will no longer automatically start since it's no longer registered as a service with the system.
ACTION
The issue is resolved in Strategy 10.0 Hotfix 1 as well as Strategy 10.1. Upgrade to the latest platform release or feature release version to take advantage of the fix.