SYMPTOM:
When attempting to save a custom visualization built using the visualization builder tool for Strategy Web, an error message similar to the following is displayed:

Error parsing xml definition: '/plugins/Reingold-Tilford_tree/WEB-INF/xml/styleCatalog.xml'.

This indicates that the plugin may have saved, however users are advised to verify that the plugin did save correctly. Strategy Web may appear unresponsive if restarted after this issue has occurred.
Steps to reproduce:
CAUSE:
This was a known issue with an earlier version of the visualization builder tool.
If Strategy Web has become unresponsive after restarting the web server, the plugin that was created when this issue happened may be corrupt.
ACTION:
If the plugin is corrupt, remove the plugin from the plugins folder and restart the web server. Strategy Web should become responsive again.
This issue has been addressed in the visualization builder provided for Strategy 10.3 and newer. Customers are advised to consider upgrading to take advantage of this fix.
WORKAROUND:
Use a different name for the visualization. Specific symbols used in the visualization name and plugin name may be causing this. For example, the hyphen symbol used here.
Instead of "Reingold-Tilford_Tree" try to use "Reingold_Tilford_Tree".
ADDITIONAL INFORMATION:
The Strategy SDK allows you to customize several Strategy products and extend and integrate the Strategy business intelligence functionality into other applications. However, before changing the way Strategy products look or behave, it is helpful to understand how the application is built. For more information regarding the Strategy products or the process of customizing Strategy products, please refer to Strategy Developer Zone (https://developer.Strategy.com).
To access the Strategy Developer Zone, you must have access to the Strategy Knowledge Base, you must have purchased the Strategy SDK, and you must be current on your Strategy maintenance agreement. If you are a US-based business and believe that you satisfy all three of these conditions but you do not have access to the Strategy Developer Zone, please contact Strategy Technical Support at support@Strategy.com or at (703) 848-8700. If you are an international business, please contact Strategy Technical Support at the appropriate email address or phone number found at https://www.Strategy.com/us/services/support/contact.
CUSTOMIZATION WARNING:
This customization is provided as a convenience to Strategy users and is only directly applicable to the version stated. While this code may apply to other releases directly, Strategy Technical Support makes no guarantees that the code provided will apply to any future or previous builds. In the event of a code change in future builds, Strategy Technical Support makes no guarantee that an updated version of this particular customization will be provided. In the event of a code change in future builds, Strategy may not be able to provide additional code on this matter even though this customization is provided at this time for this specific build. For enhancements to this customization or to incorporate similar functionality into other versions, contact your Account Executive to inquire about Strategy Consulting assistance.