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KB268204: MicroStrategy 10 Enterprise Manager Data Loader Service cannot be started with the error "The MicroStrategy Enterprise Manager Data Loader service terminated with the following service-specific error: %%4294967295"


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• Strategy


This technical document covers a know issue with MicroStrategy 10.x Enterprise Manager. The MicroStrategy Enterprise Manager Data Loader Service fails to start successfully whenever there is a failed data load in the EM_RECOVERY table.

SUMMARY
This Knowledge Base article describes a known issue with Strategy 10.x Enterprise Manager. The Strategy Enterprise Manager Data Loader Service fails to start successfully whenever there is a failed data load in the EM_RECOVERY table. A fix for this issue has been implemented in Strategy 10.4 Hotfix 3 and newer.
 
SYMPTOM
When trying to start the Strategy Enterprise Manager Data Loader Service by using Strategy Service Manager, the service fails to start successfully and automatically gets back to "stopped" status. Trying to start the Strategy Enterprise Manager Data Loader Service by using the Windows Services presents the same behavior.
 
When checking the Windows Event Viewer, the following error message can be found:


"The Strategy Enterprise Manager Data Loader service terminated with the following service-specific error: %%4294967295


CAUSE
This issue is triggered when it is not possible to correctly load the recovery point from an interrupted or failed data load from the IS_LAST_UPDATE and EM_RECOVERY tables, causing a null pointer exception during the Strategy Enterprise Manager Data Loader Service startup process.
 
ACTION
This issue is address in Strategy 10.4 Hotifx 3. Upgrade to the newest version of the Strategy software to take advantage of this fix. 
 
WORKAROUND 
This Enterprise Manager data loader service will start successfully after cleaning up the failed data loads in the Strategy Enterprise Manager Warehouse EM_RECOVERY table. 
The EM_RECOVERY table is only populated during the data load process and it is purged once the data load process is complete. Therefore, if a data load fails or is interrupted, the EM_RECOVERY table will show several rows depending on the ETL steps that were completed in the data load before it was interrupted. 
To remove all the contents form the table EM_RECOVERY, a query similar to the following can be used:
 

TRUNCATE TABLE EM_RECOVERY;


After truncating the contents of the EM_RECOVERY table, the Enterprise Manager data loader service should run successfully. In some cases, it may also be required to remove the failed data load entries from the EM_IS_LAST_UPDATE tables. A detailed explanation on  this can be found below:
 
A healthy EM_IS_LAST_UPDATE table should only have 1 row with the column IS_STATUS presenting a value of "0". This unique configuration row is marked with the column IS_WIN_BEGIN containing a value of "12/31/69 6:00:00 PM" and the IS_REP_GUID and IS_PROJ_GUID columns containing only zeros. This is a control row and can be observed as follows:

ka04W000000OfayQAC_0EM4400000029DA.jpeg

 
In all the subsequent rows, the columns IS_WIN_BEGIN and IS_WIN_END will indicate the period for which a successful data load was processed. 

ka04W000000OfayQAC_0EM4400000029D9.jpeg

 
If a data load was interrupted or failed, the incomplete data load process will be shown as an additional row with a value of "0" in the column IS_STATUS. The difference with the healthy control row is that the column IS_WIN_BEGIN will show the date for the starting period of the interrupted/failed data load process as shown below:

ka04W000000OfayQAC_0EM4400000029D8.jpeg

 
In order to remove the traces of the failed data load, the rows from the table EM_IS_LAST_UPDATE that represent failed data loads can be converted to represent successful data loads.Using the example above, it can be seen that the information was correctly migrated until 10/15/15 10:51:25 PM. After that, the failed data load can be observed with the EMLU_ID = 21. This data load now has a value of "0" in the column IS_STATUS. 

ka04W000000OfayQAC_0EM4400000029D7.jpeg

 
In order to change the failed data load entry to show up as a successful data load in the EM_IS_LAST_UPDATE table, a query similar to the one provided below can be run. In the following query 'x' is any EMLU_ID value for which IS_STATUS = 0 (other than the unique configuration row with the IS_REP_GUID and IS_PROJ_GUID columns with zeros and a IS_WIN_BEGIN column with the value 12/31/69 6:00:00 PM). This query will update the IS_STATUS of these rows to 1. 
 


UPDATE EM_IS_LAST_UPDATE SET IS_STATUS=1 where EMLU_ID ='x';


Once the failed data load entries have been updated to show up as successful data loads, a custom time window data load should be run to cover the time period of the data loads that failed.  The columns IS_WIN_BEGIN and IS_WIN_END for the rows where IS_STATUS = 0 (other than the unique configuration row) will show the time window of the data load(s) that failed. The following is the custom time window data load command that would be run in the above example: 
EXECUTE DATA LOAD "Data Load" WITH DATA FROM "10/15/2015 00:00:00 +0000" TO "10/16/2015 22:00:00 +0000" IN ENTERPRISE MANAGER "localhost" IN PORT 9999;
 
It is strongly suggested to do a full backup of the Statistics and Enterprise Manager databases prior to running any queries. The above workaround is only provided as an alternative and should not be attempted if the user is not familiar with the steps provided above. Contact Strategy Technical Support if assistance is required.

KB268204


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Knowledge Article

Published:

March 30, 2017

Last Updated:

August 14, 2018