SUMMARY:
The issue described in this article is a limitation of the DataDirect ODBC SQL Server driver. This issue occurs in earlier versions of Strategy with the DataDirect driver as well as the Native Client driver from Strategy.
SYMPTOM:
In Strategy 10.x, users are unable to run reports that contain attributes or metrics with the datatype NVarChar(max). The following error message occurs during report execution:

Error: SQL Generation Complete QueryEngine encountered error: FetchScroll. Error type: Odbc success with info. Odbc operation attempted: SQLFetchScroll. [01004:0: on SQLHANDLE] [Strategy][ODBC SQL Server Wire Protocol driver]String data, right truncated

CAUSE:
This issue is a limitation of the DataDirect ODBC SQL Server Wire Protocol driver. The driver has a character limit of 4676 characters in length, even though the column in the database can store up to 2GB.
ACTION:
CAST the column to a specified amount that does not exceed 4000 characters in length. The 4000 character limit is the specified limit for NVarChar. For example: ApplySimple("cast(#0 as NVarChar(4000))", MyNVarCharColumn).
Note: The syntax for the ApplySimple will vary depending on the database. The example above was written for a SQL Server database.