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KB2804: "Internet Explorer cannot display the webpage" error shows when going into MicroStrategy Web Main.aspx page using IIS 7 after changing the Java Heap Size


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This technical note shows how to solve one particular cause of the error "Internet Explorer cannot display the web page". The cause described in this technical note is due to incorrect syntax of a Windows registry key. The impact is limited to MicroStrategy Web 9.x product only Windows operating system, IIS 7 web server, and Internet Explorer 9. The correct solution is described in this document, and there are other solutions available here for similar errors.

SUMMARY
This technical note shows how to solve one particular cause of the error "Internet Explorer cannot display the web page". The cause described in this technical note is due to incorrect syntax of a Windows registry key. The impact is limited to Strategy Web 9.x product only Windows operating system, IIS 7 web server, and Internet Explorer 9. The correct solution is described in this document, and there are other solutions available here for similar errors.
 
SYMPTOM
When trying to access the Main.aspx page of Strategy Web 9.x the end user receives the error below.  This happens in IIS 7 web server using Internet Explorer 9.
 

ka04W00000148juQAA_0EM4400000026OU.png

 


Internet Explorer cannot display the web page

When clicking "More information" additional details show below.
 
 

ka04W00000148juQAA_0EM4400000026OQ.png

 
The IIS web server status shows that it is still running.
 
STEPS TO REPRODUCE
Follow these instructions to reproduce the issue.

  • In the web server machine, navigate to the Windows Registry Editor.  This can be accessed by running "regedit" from the Start menu.
  • Navigate to the following location:
     
    
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Strategy\JNI Bridge 64\Configuration\JVM Options\HeapMaxSize

     
  • Modify the HeapMaxSize.
ka04W00000148juQAA_0EM4400000026OW.png
  • Enter "512" under "Value data".
ka04W00000148juQAA_0EM4400000026OS.png
  •  
    WARNING
    Modifying registry values incorrectly may cause serious, system-wide problems that may require the re-installation of Microsoft Windows NT. Any edit of the registry is done at the user's own
    risk. Since these are user-initiated changes, they are not covered by any Strategy warranty. If using Microsoft Windows NT, the user should backup the registry and/or update an Emergency Repair Disk (ERD) prior to alterations.
     
  • Save the changes and restart IIS to take effect.
  • Navigate to Strategy Web in Internet Explorer 9.  The error should show.

Video:
You can find a detailed video on how this issue is reproduced here:  Tech Note 45570. Steps to reproduce
 
CAUSE
The cause of this issue is because the value under "Value data" described above has incorrect syntax.  The character "M" is required as capital letter after the numeric value of the HeapMaxSize.
 
ACTION
Add an "M" character after the numeric value put in for HeapMaxSize in the Windows Registry Editor.  Using the example in the Steps to Reproduce, the correct value under "Value data" should display as 512M.

ka04W00000148juQAA_0EM4400000026OY.png

 
Restart IIS to take effect.  After the changes have been applied, the Main.aspx page in Strategy Web should be able to be accessed successfully.

ka04W00000148juQAA_0EM4400000026Oa.png

 
ADDITIONAL TROUBLESHOOTING
If the steps above do not resolve the issue, please consider calling Strategy tech support with the following information of troubleshooting already done:

  • Results of testing with a user with the appropriate permissions to access Strategy Web, or with the Administrator user account if possible.
  • Results or output of following the above Action steps.

Other resources with different solutions to the "Internet Explorer cannot display the web page":
KB3721: Internet Explorer cannot display the webpage" error message appears when opening Strategy Web and Web Administrator 9.4.1 and above on Windows based systems with IIS
KB39747: "Internet Explorer cannot display the webpage" error message appears when clicking the history list message link sent to email using Distribution Services
KB30725: "Internet Explorer cannot display the webpage" occurs when loading the login or Portal Administrator page for the Strategy Narrowcast Subscription Portal 9.x.
 
TO LEARN MORE:
KB30885: How to increase the Java Virtual Machine Heap size for Strategy Web 9.x and 10.x running on 64 bit Windows.
 
Java Heap Size recommendations:
As JVM heap size requirements differ between customer environments, Strategy Technical Support does not provide any recommended specific values for the JVM Heap Size.
Strategy Installation and Configuration Guide 9.x Product Manual
Chapter 6. Deploying with IIS (Windows). Section: Deploying Strategy Web
 
Third Party Software Installation WARNING:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability.
Article Reference Number: 
KB2804


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Knowledge Article

Published:

May 27, 2017

Last Updated:

December 31, 2018