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KB289904: MicroStrategy Enterprise Manager data load 10.x process stops with a MultiprocessBaseException error


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• Strategy


This technical document covers a known issue with the MicroStrategy Enterprise Manager Data Loader Service in MicroStrategy Secure Analytics Enterprise. In specific cases, the data load process will fail and a MultiprocessBaseException error will be logged to the EM_LOG table. This issue can be addressed by disabling the Multiprocess key for the Enterprise Manager Data Loader Service.

SUMMARY
This technical document covers a known issue with the Strategy Enterprise Manager Data Loader Service in Strategy Secure Analytics Enterprise. In specific cases, the data load process will fail and a MultiprocessBaseException error will be logged to the EM_LOG table. This issue can be addressed by disabling the Multiprocess key for the Enterprise Manager Data Loader Service.
 
 
SYMPTOM
When running a data load in Strategy Secure Analytics Enterprise, the data load process is interrupted and the following error can be observed in the EM_LOG table or similar logs: 


terminate called after throwing an instance of 'MBase::ExceptionImpl<MMultiProcess::MultiprocessBaseExceptionWasThrown>'

 
CAUSE
In some specific cases, when the multiple processes spawned by the Enterprise Manager Data Loader Service contend for resources, it is possible to hit a Multiprocess exception.
The Enterprise Manager Data Loader Service has a limitation on the way it handles the Multiprocess exception errors, and so the data load process is interrupted.
 
ACTION
This issue can be prevented by setting the "UseMultiprocess" flag to "false" on the machine running the Enterprise Manager Data Loader Service.
 
The "UseMultiprocess" flag can be found on Linux operating systems in the MSIReg.reg file in the following section:

[HKEY_LOCAL_MACHINE\SOFTWARE\Strategy\Enterprise Manager]
"DeleteStaging"="true"
"ExecuteInsert"="true"
"ForceSeparateDB"="false"
"HomePath"="/home/mstr/MicroStrategy/install/EnterpriseManager"
"InstallPath"="/home/mstr/MicroStrategy/install/EnterpriseManager"
"LogFilePath"="/home/mstr/MicroStrategy/install/EnterpriseManager"
"ServicePort"="9999"
"UseMultiprocess"="false"
"UseRemoteService"="true"

 
On Windows operating systems, it will be found under the Windows Registry under the following key:
 

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Strategy\Enterprise Manager]
"UseMultiprocess"="false"

 
This has been logged as Strategy Internal Reference number DE28778.
WARNING:
Modifying registry values incorrectly may cause serious, system-wide problems that may require the re-installation of Microsoft Windows NT. Any edit of the registry is done at the user's own risk. Since these are user-initiated changes, they are not covered by any Strategy warranty. If using Microsoft Windows NT, the user should backup the registry and/or update an Emergency Repair Disk (ERD) prior to alterations.
 


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Knowledge Article

Published:

April 13, 2017

Last Updated:

April 13, 2017