Execute Query failed. Error type:ODBC error. Odbc operation attempted: SQLexecDirect. ORA-00942: table or view does not exist.
CAUSE:Sequences are used to produce Subscription ID dynamically when creating a Static Subscription Set. Oracle Sequences are owned by a different user while the user specified to access Object Repository for this system does not have a privilege to use Sequence.
ACTION:Make sure to grant privilege to use Sequences for the user. For the complete list or privilege required for the database user used to access Object Repository, please refer to Strategy Narrowcast Server Installation and Configuration Guide > 1. Installation > Installation Prerequisites > Database requirements.
Regarding the same error, refer to the following Strategy Knowledge Base technical note for more information:
- KB14743: `ORA-00942: table or view does not exist` error occurs when adding an address to a Static Subscription Set in Strategy Narrowcast Server 9.x against an Oracle Subscription Book Repository
- KB18844: `ORA-00942: table or view does not exist` error occurs when trying to copy a Strategy Narrowcast Server 8.x system using the Copy Repository tool in Strategy Narrowcast Server 9.x Administrator