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KB305387: Users with "Save" Privilege but Without “Web Document Design” Privilege Are Not Able to See “Save” Button in Document with Presentation Mode for MicroStrategy Web 10.2 and 10.3


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Users with "Save" Privilege but Without “Web Document Design” Privilege Are Not Able to See “Save” Button in Document with Presentation Mode for MicroStrategy Web 10.2 and 10.3

SYMPTOM:
Users with "Save" privilege but without “Web document design” privilege are not able to see “Save” button in document with Presentation mode for Strategy Web 10.2 and 10.3.
Follow the steps below to reproduce the issue:

  • Grant user “Save to My reports” privilege and uncheck “Web document design” privilege.
     
  • Log in with this user in Strategy Web and run a document in Presentation mode
     
  • Save button is missing from the menu although the user has Save privilege:
ka0PW0000000me9YAA_0EM4400000025TG.jpeg

CAUSE:
This is a known issue with Strategy Web 10.2 and 10.3.
ACTION:
The issue has been addressed in Strategy Web 10.4. Upgrade to take advantage of the fix.
 
WORKAROUND:
The following steps are intended for short term use to address this issue for Strategy 10.2 and 10.3.   In order to work around this issue, an SDK plugin needs to be created to fix the issue.  Instructions to set up the Web Customization Editor (WCE) to create this plugin can be found here: Setup WCE .

  • Using the Web Customization Editor, create a new plugin .
  • On the Application Settings tab, navigate to Strategy Web Configuration > Pages
     
  • Right click on oivm page, and navigate to Toolbars > Edit Toolbar Element
     
  • Select tbSave, and click Next
ka0PW0000000me9YAA_0EM4400000025TF.jpeg
  • Under the Advanced section, for Select the feature that will determine whether this toolbar element should be shown:, change the value from:

    save-report;enable-save-report;!rw-ive-mode-available;rw-optimized-interactive-view-mode;documents-design-mode

    to

    save-report;enable-save-report;!rw-ive-mode-available;rw-optimized-interactive-view-mode;
ka0PW0000000me9YAA_0EM4400000025TB.jpeg
  • Click Finish
     
  • Restart Web Server

 
The example provided in this document is provided “as-is” to the user and assumes that the user:

  • Can program, compile (e.g. javac, jikes, etc.), and execute Java programs
  • Can configure environment variables (e.g. JAR files, property files, etc.)
  • Have all the necessary tools to create Java applications (JDK, IDE, etc.)
  • Has access to the Strategy SDK documentation.
  • Has read the customization warning at the bottom of this document

PREREQUISITES: 
For the sample to work, the Strategy Web JAR files must be accessible by the Java Runtime Environment. The Strategy Web JAR files can be found under:

  • Strategy Web Universal (JSP): {web_root}/WEB-INF/lib directory.
  • Strategy Web (.NET): Program Files\Common Files\Strategy directory.

Note: More elaborate programs will require additional library files and are out of the scope of this document.
ADDITIONAL INFORMATION:
The Strategy SDK allows you to customize the standard Strategy Web interface, and extend and integrate the Strategy business intelligence functionality into other applications. However, before changing the way Strategy Web products look or behave, it is helpful to understand how the application is built. For more information regarding the Strategy Web architecture or the process of customizing Strategy Web, please refer to MicroStrategy Developer Hub.
To access the Strategy Developer Hub, you must have access to the Strategy Knowledge Base, you must have purchased the Strategy SDK, and you must be current on your Strategy maintenance agreement. If you are a US-based business and believe that you satisfy all three of these conditions but you do not have access to the Strategy Developer Hub, please contact Strategy Technical Support at support@microstrategy.com or at (703) 848-8700. If you are an international business, please contact Strategy Technical Support at the appropriate email address or phone number found at https://www.microstrategy.com/en/support/contact-support.
CUSTOMIZATION WARNING:
This customization is provided as a convenience to Strategy users and is only directly applicable to the version stated. While this code may apply to other releases directly, Strategy Technical Support makes no guarantees that the code provided will apply to any future or previous builds. In the event of a code change in future builds, Strategy Technical Support makes no guarantee that an updated version of this particular customization will be provided. In the event of a code change in future builds, Strategy may not be able to provide additional code on this matter even though this customization is provided at this time for this specific build. For enhancements to this customization or to incorporate similar functionality into other versions, contact your Account Executive to inquire about Strategy Consulting assistance.


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Knowledge Article

Published:

May 30, 2017

Last Updated:

February 15, 2024