EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB30738: "ORA-01426: numeric overflow" error occurs when trying to edit reports in MicroStrategy Intelligence Server Universal 9.x on AIX


Community Admin

• Strategy


"ORA-01426: numeric overflow" error occurs when trying to edit reports in MicroStrategy Intelligence Server Universal 9.x on AIX

SYMPTOM:
When trying to edit a report object via a 3-tier project source connected to a Strategy Intelligence Server Universal 9.x on an AIX environment, the following error is received:

ka04W000000OcdFQAS_0EM440000002WtJ.jpeg


Sample Code/Error
Database error <>: Fetch failed. Error type: Odbc error. Odbc operation attempted: SQLFetch. ORA-01426: numeric overflow

The above described error can also appear when trying to do one of the following:

  • Copy the report object
  • Search for dependents
  • Search for components
  • See the Properties of the report object

CAUSE:
The IANAAppCodePage value is not appropriately set for the Strategy ODBC Oracle Wire Protocol driver on the AIX Strategy Intelligence Server Universal 9.x machine. This value is located in the ODBC.ini file and is used by the driver manager to convert Unicode instructions to ANSI and vice-versa. This value determines the code page that is used in the conversion.
 
ACTION:
By default on an AIX machine, the IANAAppCodePage value is set to 106 when a DSN for Oracle databases is created; 106 is the value for UTF-8. This value needs to be changed according to the code page used by the database.
To do this, follow the steps below:

  1. Go to the odbc.ini file. This file is located in the <HOME_PATH> directory for the Strategy product installation.
  2. Make a backup copy of this file, for later use if necessary.
  3. Open the odbc.ini file.
  4. Update the value of IANAAppCodePage for the appropriate Oracle DSN. Go to the section for this Oracle DSN and change the IANAAppCodePage value from 106 to the correct value. If there is no entry for IANAAppCodePage value, add an entry to the text file under the DSN. The following is an example DSN configuration entry in the odbc.ini file:
     
    
    IpAddress=1.1.1.1
    
    Database=mydb
    
    TcpPort=1521
    
    Driver=/MSTR HOME/install/lib32/MYoraXX.so
    
    Description=Strategy ODBC Driver for Oracle Wire Protocol
    
    ApplicationUsingThreads=1
    
    ArraySize=60000
    
    CachedCursorLimit=32
    
    CachedDescLimit=0
    
    CatalogIncludesSynonyms=1
    
    CatalogOptions=0
    
    DefaultLongDataBuffLen=1024
    
    EnableDescribeParam=1
    
    EnableNcharSupport=1
    
    EnableScrollableCursors=1
    
    EnableStaticCursorsForLongData=0
    
    EnableTimestampWithTimeZone=0
    
    IgnoreODBCTimeStampLiteral=1
    
    LocalTimeZoneOffset=
    
    LockTimeOut=-1
    
    ProcedureRetResults=0
    
    UseCurrentSchema=1
    
    IANAAppCodePage=106
    

     
    NOTE: There is an IANAAppCodePage = 106 in the section. Do not change this value as a change here will apply to all the DSNs in the odbc.ini file.
  5. Save the odbc.ini file.

Consult the following Data Direct technical document to determine the correct IANAAppCodePage value, according to the database code page:
http://www.datadirect.com/support/troubleshooting/su_faq_iana/index.ssp
 
WARNING:
Create a backup of odbc.ini file before making any changes to this file.


Comment

0 comments

Details

Knowledge Article

Published:

July 18, 2017

Last Updated:

July 18, 2017