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KB30785: The Dynamic Date filter option is not available when creating a filter for a date attribute


Stefan Zepeda

Salesforce Solutions Architect • Strategy


After creating a date attribute in MicroStrategy, filters based on the attribute do not have the option for Dynamic Dates available.

SYMPTOM:
After creating a date attribute in Strategy, filters based on the attribute do not have the option for Dynamic Dates available.
 
STEPS TO REPRODUCE:

  • Create a date attribute and set the ID type to be "text".
     
ka02R000000kXcfQAE_0EM440000002EOT.jpeg
  • Create a filter based on the Date attribute.
  • Select ID and try to define a Dynamic Date the option does not exist. There should be a second button on the prompt line if the dynamic date option was enabled.
     
ka02R000000kXcfQAE_0EM440000002EOR.jpeg

 
CAUSE:
The ID format type was set to text in the attribute editor. The ID needs to be of Date or DateTime type in order to use it in a Dynamic Date flter.
 
ACTION:
Change the format type to Date or DateTime in the attribute editor.


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Knowledge Article

Published:

June 14, 2017

Last Updated:

June 14, 2017