EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB317023: MicroStrategy Enterprise Manager 10.x fails to start with error: java.lang.NumberFormatException


Community Admin

• Strategy


MicroStrategy Enterprise Manager 10.x, it may fail with an error. Caused due to an invalid maximum size setting for the log file set as the logging destination for ETL > Migration SQL

SYMPTOM

When attempting to start Strategy Enterprise Manager 10.x, it may fail with an error similar to the following: 
 


com.Strategy.maem.exceptions.EMException: javax.management.RuntimeMBeanExce
ption: com.Strategy.maem.exceptions.EMRuntimeException: java.lang.NumberFor
matException: For input string: "4294967295"

 
Note: The above error can be seen when running the executable "MSTREMService.exe" from command line or in the advanced error logs that can be generated through the following command: 

C:\Program Files (x86)\MicroStrategy\Enterprise Manager\MSTREMService.exe" -vvv "C:\Program Files (x86)\MicroStrategy\Enterprise Manager\MSTREMService.dll"

 
Additionally, if attempting to start via command line using the mstrctl command, the following error will be thrown: 
 

MSTRExec Error: Exiting with error -1 (0xFFFFFFFF): MExec::ApplicationProxy_Impl
::RunInternal: Attempt to 'start' failed with error code -1 (0xFFFFFFFF)

 
CAUSE
The issue is caused due to an invalid maximum size setting for the log file set as the logging destination for ETL > Migration SQL. It is not possible to set such an invalid value by using the Strategy Diagnostic Utility which restricts the maximum file size to 999999999. However, in some cases the value may have been manually modified to reflect a size larger than 2147483647 which will end up preventing the Strategy Enterprise Manager Service from starting.
 
ACTION
The following steps can be followed to correct the file size and allow the Enterprise Manager Service to start.
 

  1. Open Strategy Diagnostic Utility.
  2. Switch configuration from CastorServer Instance to Machine Default.
  3. Scroll down to Component ETL and take note of the currently chosen File Log for the Dispatcher Migration SQL.
  4. Click the log destination editor button and select the log destination that was set as the file log from step 3.
  5. Change the value of Max. File size (KB) from it's current value(which will not be correct, as the interface cannot handle the larger values) to a value within the range of 1-999999999.
  6. Hit save to close the diagnostics editor. 
  7. After this change, the Strategy Enterprise Manager Data Load service can be started. 

 


Comment

0 comments

Details

Knowledge Article

Published:

June 5, 2017

Last Updated:

June 8, 2017