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KB318709: The Service Principle Name (SPN) field is greyed out for Kerberos Authentication mode when creating a DSN using the MicroStrategy Apache Spark SQL ODBC Driver in the Windows Data Sources (ODBC) Administrator.


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This Technical Note describes an issue where the Service Principle Name (SPN) field is greyed out for Kerberos Authentication mode when creating a DSN using the MicroStrategy Apache Spark SQL ODBC Driver in the Windows Data Sources (ODBC) Administrator.

SUMMARY:
This Technical Note describes an issue where the Service Principle Name (SPN) field is greyed out for Kerberos Authentication mode when creating a DSN using the Strategy Apache Spark SQL ODBC Driver in the Windows Data Sources (ODBC) Administrator.
 
SYMPTOM:
In Strategy 10.4 and higher, when creating a DSN using the Strategy ODBC Driver for Apache Spark SQL in the Windows Data Sources (ODBC) administrator, the Service Principle Name text field is greyed out when using the Kerberos authentication method.
 
STEPS TO REPRODUCE:
Follow these steps to reproduce the issue in a Strategy Tutorial Environment.

  • Open the ODBC data source administrator tool in windows
  • Navigate to the System DSN tab > Add > Strategy ODBC Driver for Apache Spark SQL > Finish
ka04W000000OaeQQAS_0EM440000002C0X.jpeg
  • Figure 1: Creating a DSN for Apache Spark in Data Source (ODBC) Administrator Using Strategy ODBC Driver for Apache Spark SQL
  • Navigate to the Security tab and Under authentication method, select “4-Kerberos” from the drop-down
ka04W000000OaeQQAS_0EM440000002C0I.jpeg
  • Figure 2: Service Principle Name greyed-out for "4 - Kerberos" Authentication Method
  • Note that the Service Principle Name field is greyed out
     

 
CAUSE:
This is an identified defect by Strategy in the GUI for the current driver we ship on Windows.
 
ACTION:
This issue has been rectified in Strategy 10.7. Please upgrade to this version to take advantage of a fix or follow the workaround below.
 
WORKAROUND:
To work around this issue, navigate to the Advanced Tab and set the SPN as part of the Extended Options field. For example, in this section simply add SPN=Service_Name/Fully_Qualified_Domain_Name@REALM.COM. 

ka04W000000OaeQQAS_0EM440000002C0F.jpeg

Figure 3: Set the SPN as part of the Extended Options in the Advantage Tab.
 
 
KB318709


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Knowledge Article

Published:

April 14, 2017

Last Updated:

December 29, 2018