SYMPTOM:
When executing a report against a Teradata warehouse in Strategy Desktop, the following error may occur:

Sample Code/Error
QueryEngine encountered error: Unknown failed. Unable to connect. Error type: System call error. Error communicating with connection process. Process hung.. Error in Process method of Component: QueryEngineServer, Project, Job 161307, Error Code= -2147212544.
When running the report in 2-tier, the following error occurs:

Sample Code/Error
QueryEngine encountered error: Connect failed. Error type: Odbc error. Odbc operation attempted: SQLDriverConnect. User password has expired Password has expired, please use MODIFY USER statement to generate a new password.
NOTE: If 2-tier works but 3-tier fails, connection mapping could be configured for the user.
Also, when logging into the database directly as the database login user using a native database tool, the following error occurs:

Sample Code/Error
User password has expired
Unable to open a session for user .
There is another session currently open.
Use that session to assign a new password.
CAUSE:
The report was unable to return from the database because the password for the database login expired.

If connection mapping is configured, the password for the database login object specified for the user could have expired.
ACTION:
Perform either of the following actions to resolve the issue: