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KB319453: Enterprise Manager Data Loader Service is not seen in Service Manager on a Windows machine after upgrading from MicroStrategy 9.X to MicroStrategy 10.X


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SUMMARY
This Technical Note covers an issue where the Enterprise Manager Data Loader service is not available after an upgrade from Strategy 9.X to Strategy 10.X. There are two possible workarounds to install the service.
 
SYMPTOM
After upgrading from Strategy 9.x to Strategy 10.4 on a Windows machine that had the Enterprise Manager component installed, the Enterprise Manager Data service is not seen as an option in Strategy Service Manager. The service still is not seen even after uninstalling and reinstalling the Enterprise Manager component.
 
In addition, the 10.4 Strategy Data Loader Service MSTREMService.exe is seen in the correct location on disk while the Windows Service entry still points to the 9.x service MAEMETLS.exe incorrectly.
 
Disk location C:\Program Files (x86)\Strategy\Enterprise Manager with correct 10.4 Enterprise Manager files:

ka04W00000148HaQAI_0EM44000000299A.jpeg

 
Windows Service entry with outdated 9.x reference to MAEMETLS.exe. (This window can be seen by searching for and selecting "Services" in the Start menu, then double clicking the Strategy Enterprise Manager Data Loader entry):
 

ka04W00000148HaQAI_0EM44000000299E.jpeg

 
CAUSE
After the upgrade, the Windows registry entry for the 9.x Enterprise Manager Data Loader Service still exists even though the application files have been uninstalled.
 
WORKAROUND
There are two possible workarounds. Option A is to remove the reference to the old service by using the "sc delete" command. Option B is to do a complete uninstall of all Strategy products on the machine.
 
Option A: Use the "sc delete" command to delete the reference to the old service. NOTE: if using this workaround please be sure to first create a backup of the Windows registry.
 
Steps:

  1. Create a backup of your Windows registry
  2. Uninstall the Enterprise Manager component. This can be done by going to "Uninstall a Program" in Windows Control Panel, right clicking on Strategy Secure Enterprise and selecting "Change" to launch the install utility. Choose the Modify install option. In the screen that presents the Strategy components to install/uninstall, uncheck the Enterprise Manager component to uninstall it.

​

ka04W00000148HaQAI_0EM44000000299C.jpeg
  1. Run the following command in Windows Command Prompt:  


​sc delete MAEMETLS

  1. Restart the machine
  2. Reinstall the Enterprise Manager component by running a Modify install as in step 2 and checking the Enterprise Manager component this time to install it.

 
Option B: Run a complete uninstall of all Strategy products, including a special cleanup utility that will remove all previous Strategy references by following the steps outlined in the following Technical Note: 
https://community.Strategy.com/s/article/KB307710-How-to-uninstall-Strategy-Analytics-Enterprise . 
After the uninstallation is complete, reinstall the desired Strategy components on the system through the install package as usual.


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Knowledge Article

Published:

June 6, 2017

Last Updated:

June 6, 2017