SYMPTOM
An SDK solution using the Common External Security Module Customizations (for more information click here) that sends the URL back to the Strategy Web Server from the Service Provider using the event 3010 is displaying the error “An error occurred on this page. The contents of this page could not be displayed because the Intelligence Server is not running. Please contact the Administrator.” in Strategy 10.4 Hotfix 2. In previous releases the URL that uses the same event "3010" URL http:// <webserver>/MicroStrategy/asp/main.aspx?evt=3010 was working with no errors.

STEPS TO REPRODUCE
In any internet browser, type
http:// <webserver>/MicroStrategy/asp/main.aspx?evt=3010
For example,
http://www.myweb.com/MicroStrategy/asp/main.aspx?evt=3010
CAUSE
Starting in Strategy 10.4 HF2, there were some modifications to force the user to provide a valid server name for security reasons. The URL works fine if the user has already established a session with one project.
SOLUTION
There are 2 ways to fix this.
1) In the URL, specify the Port number and server name of the Intelligence Server like shown below:
http://<webserver>/MicroStrategy/asp/main.aspx?evt=3010&src=Main.aspx.3010&Port=<portnumber>&Server=<I-server>
For example,
http://www.myweb.com/Microstrategy/asp/main.aspx?evt=3010&src=Main.aspx.3010&Port=34952&Server=myserver

2) If the option 1 is not a viable solution, there is a way to automatically select the next active intelligence server, by providing a fake server name in the URL. This configuration requires a plugin, the steps are demonstrated in the article KB45848:
https://community.strategy.com/article/KB45848-How-to-dynamically-select-Intelligence-Servers-in-a
Once the change has been applied, use the following URL, passing the Project name and the Server parameter as default as shown below:
http://<webserver>/MicroStrategy/asp/main.aspx?evt=3010&src=Main.aspx.3010&Project=<projectname>&Server=default

ADDITIONAL INFORMATION:
The Strategy SDK allows you to customize the standard Strategy Web interface, and extend and integrate the Strategy business intelligence functionality into other applications. However, before changing the way Strategy Web products look or behave, it is helpful to understand how the application is built. For more information regarding the Strategy Web architecture or the process of customizing Strategy Web, please refer to the MicroStrategy Developer Hub.
To access the Strategy Developer Hub, you must have access to the Strategy Knowledge Base, you must have purchased the Strategy SDK, and you must be current on your Strategy maintenance agreement. If you are a US-based business and believe that you satisfy all three of these conditions but you do not have access to the Strategy Developer Hub, please contact Strategy Technical Support at support@microstrategy.com or at (703) 848-8700. If you are an international business, please contact Strategy Technical Support at the appropriate email address or phone number found at https://www.microstrategy.com/en/support/contact-support.
CUSTOMIZATION WARNING:
This customization is provided as a convenience to Strategy users and is only directly applicable to the version stated. While this code may apply to other releases directly, Strategy Technical Support makes no guarantees that the code provided will apply to any future or previous builds. In the event of a code change in future builds, Strategy Technical Support makes no guarantee that an updated version of this particular customization will be provided. In the event of a code change in future builds, Strategy may not be able to provide additional code on this matter even though this customization is provided at this time for this specific build. For enhancements to this customization or to incorporate similar functionality into other versions, contact your Account Executive to inquire about Strategy Consulting assistance.
KB324148