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KB325236: Cannot install MicroStrategy Desktop 10.0 – 10.3 under the local system account.


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• Strategy


SYMPTOM:
Automated installations offer the ability for administrators to run unattended installations while still customizing certain aspects of the Strategy installation. Please note that automated and silent installations require advanced techniques such as creating and running response.ini files. Therefore, automated and silent installations should be handled by system administrators with full knowledge of the environment and the desired Strategy installation. Please refer to the Desktop User Guide for more details on installing Strategy desktop with an automatic installation.
 
For some applications, the installations need to be run under the local system account.  However, the installation cannot be run under the local system account for Strategy Desktop 10.0 – 10.3. After running the installation command, the Strategy Desktop – InstallShield Wizard window will appear as seen below, but the installation will never run.
 

ka04W000000Oh3PQAS_0EM44000000297u.jpeg

 
Additionally, the StrategyDesktop-64bit.exe process will be seen in Windows Task Manager running under the system account. Once the Strategy Desktop – InsallShield Wizard window disappears, the StrategyDesktop-64bit.exe process will end in Windows Task Manager as well.
 

ka04W000000Oh3PQAS_0EM44000000297w.jpeg

 
STEPS TO REPRODUCE:

  1. On the machine, create the following path: C:\Users\Administrator\Desktop\MSTR\Files.
  2. In this location, place the Desktop .exe file which can be downloaded from the MicroStrategy download site along with the response.ini file and setup.iss file.
  3. Download PsExec from Windows SysInternals and place it in the C:\ drive.
  4. Open Command Prompt.
  5. Run the command cd \ to navigate to the root directory where PsExec is located.
  6. Run the following command: psexec -i –s cmd.exe.
  7. Open Windows Task Manager and end process explorer.exe.
  8. In the elevated command shell, run the following command: start explorer.exe.
  9. Run the following command to run the install under the local system account.
    
    "C:\Users\Administrator\Desktop\MSTR\Files\StrategyDesktop-64bit.exe" --Responsefile="C:\Users\Administrator\Desktop\MSTR\Files\response.ini" -f1"C:\setup.iss" -f2"C:\Windows\options\logs\StrategyDesktop10.3\StrategyDesktop_x64_Install.log"

  10. Notice the Strategy Desktop – InstallShield Wizard appears, but the installation never runs.

 
CAUSE:
Strategy’s installation uses the 3rd party component InstallShield. In Strategy 10.4, InstallShield was upgraded to a newer version which fixed this issue.
 
ACTION:
This issue has been addressed in Strategy Desktop 10.4. Upgrade to this version to take advantage of this fix.
 
THIRD PARTY SOFTWARE INSTALLATION WARNING:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability.


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Knowledge Article

Published:

June 5, 2017

Last Updated:

June 5, 2017