SYMPTOM:
Certain components are not listed in the Diagnostic Configuration tool as expected, as shown in the image below:

Notice that the "Export Engine" component is not shown.
CAUSE:
One possible cause of this issue is that the corresponding keys and string values are missing in the Windows registry.
ACTION:
Export corresponding registry keys from a healthy machine and then import the keys to the problematic system.
The following steps indicate how to restore the "Export Engine" component :
HKEY_LOCAL_MACHINE\SOFTWARE\Strategy\Diagnostics\Log2 HKEY_LOCAL_MACHINE\SOFTWARE\Strategy\DSS Server\Instances\CastorServer\Diagnostics\Log2
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Strategy\Diagnostics\Log2 HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Strategy\DSS Server\Instances\CastorServer\Diagnostics\Log2
Notice the "Export Engine" component is now available as shown in the image below:

WARNING:
Modifying registry values incorrectly may cause serious, system-wide problems that may require the re-installation of Microsoft Windows NT. Any edit of the registry is done at the user`s own risk. Since these are user-initiated changes, they are not covered by any Strategy warranty. If using Microsoft Windows NT, the user should backup the registry and/or update an Emergency Repair Disk (ERD) prior to alterations.