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KB33558: "Data loading has failed! An error occurred while attempting to open the log file" error occurs when performing a manual dataload in MicroStrategy Enterprise Manager 9.x.


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• Strategy


The following knowledge base article describes one possible cause of the error "Data loading has failed! An error occurred while attempting to open the log file" in Enterprise Manager 9.x.

SYMPTOM:
When performing a manual dataload in Strategy Enterprise Manager 9.x, it will fail with multiple errors.  The following messages may be seen when the first failure occurs: 
 

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"An error occurred while attempting to open the log file: Path/File access error"

 
Or in some instances, the following message can be seen:
 

"An error occurred while attempting to open the log file: File not found"

 
When trying to open or delete the file, it will not allow any actions to be performed on it and will say that it is in use by another program. Going into the Strategy Enterprise Manager Console and specifying a different log location will remove this error, but when attempting to perform the dataload again with a custom time window, it will return a different error.
 

ka04W000000OeHpQAK_0EM440000002Apd.jpeg

 
"Data loading has failed! A previous instance of the Data Migration was found running. Exiting."  
 
 
CAUSE:
The reason why these errors would be seen when running a manual dataload is because the MAEMETL.exe process is already running from either a previous or another user's session. When this process is run, it locks the MSTRMigration.log file for it to write data to and that is why the first set of errors are seen.
 
For other reasons why the MAEMETL.exe process would cause the following error, refer to the technical note below.
KB16583: 'A previous instance of the Data Migration was found running. Exiting' error message appears when running the Data Load process in MicroStrategy Enterprise Manager 9.x
 
ACTION:
Follow the steps below to get the manual data load process to complete successfully: 

  • Close the Enterprise Manager Console
  • Open task manager on Windows (Start->Run->taskmgr or ctrl+alt+del)
  • Find running MAEMETL.exe processes and end them
  • Open the Enterprise Manager Console and start the manual data load

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Knowledge Article

Published:

June 12, 2017

Last Updated:

June 12, 2017