EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB33935: Windows Performance Monitor does not log MicroStrategy Server Jobs or MicroStrategy Server Users performance counters to file for MicroStrategy Server 10.x.


Community Admin

• Strategy


Windows Performance Monitor does not log MicroStrategy Server Jobs or MicroStrategy Server Users performance counters to file for MicroStrategy Server 10.x.

SYMPTOM:
Often it is desired to use the Windows Performance Monitor to log performance counters regarding the Strategy Intelligence Server 9.x activity so that it can be viewed along side system counters. The following technical notes have more information on logging performance counters in Windows:

  • KB14624: How to enable logging of performance counters using Microsoft Windows XP and 2003 Performance Monitor for MicroStrategy Intelligence Server 9.x and 10.x
  • KB19154: Recommended performance logging counters to enable when troubleshooting memory or performance issues in MicroStrategy Intelligence Server 9.x in Microsoft Windows environments

When setting up the Strategy Server Jobs or Strategy Server Users performance counters to log to a file, the counter log file does not contain any information for these counters. The following warning may be seen in the Application log of the Windows Event Viewer:
 

ka04W000000Oh6QQAS_0EM440000002AoB.png

 
Sample Code/Error
The service was unable to add the counter '\\<MACHINENAME>\Strategy Server Users(CastorServer)\Open Sessions' to the <LOGNAME> log or alert. This log or alert will continue, but data for that counter will not be collected. The error returned is: The specified object is not found on the system.
CAUSE:
This is a known issue with Strategy Server 9.x performance counters.
ACTION:
Strategy will continue to investigate and post updates as soon as they are available.
 
WORKAROUND:
Log the Strategy Server Jobs and Strategy Server Users performance counters using the Strategy Diagnostics Configuration tool:
KB13313: How to enable logging of performance counters using the Diagnostics and Performance Logging tool for MicroStrategy Intelligence Server 9.x in Microsoft Windows and Unix
 


Comment

0 comments

Details

Knowledge Article

Published:

June 4, 2017

Last Updated:

June 4, 2017