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KB34172: When trying to delete an incomplete project, an error is thrown: "Project [project name] with ID [project ID] cannot be deleted because it is in use by [user] on [machine] since [timestamp]. Please contact your administrator for more information.


Stefan Zepeda

Salesforce Solutions Architect • Strategy


When trying to delete an incomplete project, an error is thrown: "Project [project name] with ID [project ID] cannot be deleted because it is in use by [user] on [machine] since [timestamp]. Please contact your administrator for more information.

SYMPTOM:
When a user tries to delete an incomplete project through either Strategy Desktop or Command Manager, the following error message is thrown:


Project '<project name> with ID '<project GUID>' cannot be deleted because it is in use by '<user>' on '<machine>' since <timestamp>. Please contact your administrator for more information.

 

 
CAUSE:
This error is thrown because a session that connects to the project  was established and left lingering on the metadata, therefore leaving the project in a locked state. This lock though, cannot be released through Strategy Desktop because the project is incomplete. 
 
ACTION:
Ensure that you have a backup of the metadata in place.
Run the SQL query below to release all sessions from the incomplete project:

DELETE FROM DSSMDOBJLOCK WHERE OBJECT_ID = '<GUID of incomplete project>'

 
This will release the lock that was left behind, and then the user will be able to delete the project via Strategy Desktop or Command Manager.
 


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Knowledge Article

Published:

December 29, 2017

Last Updated:

March 12, 2018