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KB34851: "Message not found in user history list..." appears when using MicroStrategy Web SDK to determine whether a document contains prompts.


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• Strategy


"Message not found in user history list..." appears when using the following SDK code to determine whether a document contains prompts.

Symptom:
 
"Message not found in user history list..." appears when using the following SDK code to determine whether a document contains prompts.
 
       WebDocumentSource documentSource = userSession.getFactory().getDocumentSource();
       documentSource.setExecutionFlags(EnumDSSXMLDocExecutionFlags.DssXmlDocumentExecuteStatic);
 
       WebDocumentInstance docInstance = documentSource.getInstance(guid);
       docInstance.setAsync(false);
 
       int status = docInstance.pollStatus()
       WebPrompts prompts = docInstance.getPrompts();
 
       Enumeration enu = prompts.elements();
       while ( enu.hasMoreElements()) {
           WebPrompt prompt = (WebPrompt)enu.nextElement();
           System.out.println(`doc prompt name: ` + prompt.getName());
      }
 
 
Cause:
 
Using WebDocumentInstance.getInstance(documentID) only when the document object exists in memory. If the object does not exist in memory, the exception gets thrown. Follow the instruction under Action to avoid this error message.
 
 
Action:
 
getNewInstance(java.lang.String documentID)  should be used to instanciate the document object that is not available in memory yet.
 
 
ADDITIONAL INFORMATION:
The Strategy SDK allows users to customize the standard Strategy Web interface, and extend and integrate the Strategy business intelligence functionality into other applications. However, before changing the way Strategy Web products look or behave, it is helpful to understand how the application is built. For more information regarding the Strategy Web architecture or the process of customizing Strategy Web, refer to the Strategy Developer Zone (https://support.Strategy.com/MSDL/home.asp).
 
To access the Strategy Developer Zone, the user must have access to the Strategy Knowledge Base, must have purchased the Strategy SDK, and must be current on their Strategy maintenance agreement. If you are a US-based business and believe that you satisfy all three of these conditions but you do not have access to the Strategy Developer Zone, contact Strategy Technical Support at support@Strategy.com or at (703) 848-8700. If you are an international business, contact Strategy Technical Support at the appropriate email address or phone number found at https://www.microstrategy.com/en/support/contact-support.
 
CUSTOMIZATION WARNING:
This customization is provided as a convenience to Strategy users and is only directly applicable to the version stated. While this code may apply to other releases directly, Strategy Technical Support makes no guarantees that the code provided will apply to any future or previous builds. In the event of a code change in future builds, Strategy Technical Support makes no guarantee that an updated version of this particular customization will be provided. In the event of a code change in future builds, Strategy may not be able to provide additional code on this matter even though this customization is provided at this time for this specific build. For enhancements to this customization or to incorporate similar functionality into other versions, contact your Account Executive to inquire about Strategy Consulting assistance.


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Knowledge Article

Published:

June 23, 2017

Last Updated:

June 23, 2017