EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB34953: “Error message: too many connections SMTP Error: 421 Unknown error" error message appears in the DSSErrors log when sending many email subscriptions at the same time in MicroStrategy


Community Admin

• Strategy


"Error message: too many connections SMTP Error: 421 Unknown error" error message appears in the DSSErrors log when sending many email subscriptions at the same time in MicroStrategy

SYMPTOM:
When users create a great number of Subscriptions to send emails simultaneously using Distribution Services, sometimes they can see the error below in the DSSErrors log:
 
2010-12-06 16:11:19.235-08:00 [HOST:TEST3][PID:3788][THR:17832][Kernel][Error] Distribution Service: MSIDeliveryEngine::hDelivery: Delivery Failed. Error string from ExecuteMultiProcess too many connections SMTP Error: 421 Unknown error
Additionally, users that have enabled ‘Request notification on failure’ under Delivery Managers > Transmitters > Email configuration, get an email with the information shown below:
 


Dear Administrator:
The following Email delivery was not successful.
Delivery/update and destination information:
Run at: 12/1/2010 6:30:08 PM
Recipient name: Administrator
Email address: emailaddress@host.com
Error message: too many connections SMTP Error: 421 Unknown error
 
Subscription Information
 
Created by: Administrator
Report/Document name: Report 1
Project name: Test

  
CAUSE:
When Strategy Intelligence Server is connecting to the SMTP server, it is issuing a new connection per email. If users send enough emails simultaneously to reach the maximum number of connections that the SMTP server allows, users will see the error message and emails will not be delivered successfully.
ACTION:
In order to alleviate this issue, users could send a request to the mail server administrator to change the maximum number of concurrent connections for a single IP address.
  
 


Comment

0 comments

Details

Knowledge Article

Published:

June 5, 2017

Last Updated:

June 5, 2017