The results for this report are no longer available. Possible reasons are a) History List message results are unavailable, b) Insufficient privileges for executing multiple reports simultaneously, or c) the Working Set has reached the maximum number of reports.
CAUSE:
One possible cause for this issue is that when the owner of the subscription created it, the subscription was created using a contact instead of an actual Strategy user. If a contact is selected instead of a Strategy user, the history list message will only be created for the owner of the subscription. Thus when the other Strategy user logs in, they won't be able to access the message.
ACTION:
If it is desired to have a user access report data from the history list when creating an email subscription with the option for a link to the history list message, make sure that the subscription is created using a Strategy user object and not a contact object.