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KB36561: "Scan MD encountered an internal error, the process has been cancelled" error message appears when running ScanMD Schema Collection Verification against MicroStrategy metadata


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This article discusses an internal error seen when running ScanMD and a potential cause and fix for the internal error

SYMPTOM:
When running ScanMD Schema Collection Verification against Strategy metadata, the following error message appears:

ka04W000000OfhFQAS_0EM440000002DhM.jpeg


Scan MD encountered an internal error, the process has been cancelled.

 
CAUSE:
This is a generic error message. ScanMD will always pop up such internal errors if a backend error happens, such as the not being able to access the metadata due to a network problem.  In this particular scenario, the cause was that the Schema Collection Verification test reached the default 5 minutes metadata query timeout setting. 
 
ACTION:
On the ScanMD machine, increase following registry key value to workaround this 5 minutes timeout limit.  The key's value is in seconds:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Strategy\Data Sources\<Data Source Name>\MDBaseQueryTimeOut

 
The Strategy Internal Reference Number for the issue discussed in this technical note is 478858.


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Knowledge Article

Published:

April 13, 2017

Last Updated:

October 18, 2017