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KB36645: "There is no project to transfer" and "Cannot load data from Project <Project Name>. This could be because the Project is unloaded, idle or was deleted" errors occur when attempting to perform a dataload in MicroStrategy Enterprise Manager


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"There is no project to transfer" and "Cannot load data from Project <Project Name>. This could be because the Project is unloaded, idle or was deleted" errors occur when attempting to perform a dataload in MicroStrategy Enterprise Manager 9.x

SYMPTOM:
When performing a Strategy Enterprise Manager 9.x dataload, the following error message is displayed and generated in the MSTRMigration.log file:
 
Displayed:
Sample Code/Error
Data loading has failed! There is no project to transfer; this could be because all the projects are unloaded, idle or deleted
 
MSTRMigration.log:
Sample Code/Error
WARNING: Cannot load data from Project <Project Name>. This could be because the Project is unloaded, idle or was deleted.
 
 
CAUSE:
There are two possible causes for this issue:

  • Project Source configuration in Developer 9.x is set to a server name instead of an IP address. In this case the server name is unable to be resolved to a valid IP address by the Strategy Enterprise Manager machine. (For example, using "MyIntelligenceServer001" instead of 192.168.1.1)
  • The 3-tier Project Source is configured for Windows Authentication. For more information on this cause, refer to the following Strategy Knowledge Base technical note:
  • KB30809: The MicroStrategy Enterprise Manager 9.x data load fails with the error “There is no project to transfer; this could be because all the projects are unloaded, idle or deleted"

 
ACTION:
To resolve the issue of the IP address not resolving correctly perform one of the following actions:

  • Reconfigure the Project Source to use the known valid IP instead of the machine name:
    • In Strategy Desktop, right click on the desired Project Source and select "Modify Project Source".
    • Change the 'Server name' field to use an IP address instead of the machine name:
       
ka04W000000Of6kQAC_0EM440000002AdZ.png
    • Click OK
  • Reconfigure the HOSTS file on the Enterprise Manager 9.x machine.
    WARNING: This action should only be performed by a System Administrator. Full Windows administrator privileges on the machine are required for this action.

    Sample Code/Error
    0.0.0.0 hostname

    If the server host name already exists, update the IP address with the new valid one.
     
    • The HOSTS file is located in: C:\Windows\system32\drivers\etc\
    • Open the file using Notepad (if there is a security warning about the file not being able to be modified, run Notepad as Administrator and open the file)
    • Instructions on how to add hostnames and IP addresses are at the top of the file. Add the actual machine IP Address and short host name to the end of the file in the following format:
    • Save the file

 
 


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Knowledge Article

Published:

June 3, 2017

Last Updated:

June 3, 2017